The infamous CKErrorDomain 15


iCloud sucks. Sonoma made iCloud even suckier than before. Use Bonjour.

Thanks. I found this thread after a quick internet search because I’ve been getting the same error.

I just switched to Bonjour. No more errors, but items I’ve just added on my Mac aren’t showing up on my phone yet. Maybe I just need to wait a bit longer?

  • Is DEVONthink To Go open and frontmost?

  • Is DEVONthink running on the Mac?

  • Are they both on the same network?

I was completely cordial… I am not exactly sure how you saw this anyway other than that. When someone tells me I don’t know what I am talking about, as if I just post some random or lacking post, then yes… I will return fire in kind. From my initial post, despite my “please don’t dismiss this as Apple”, I was hit from all sides. As I said, I found it hard to believe that Apple would have a product failure of this magnitude, which happens every single day for years without resolution. Read the whole thread, then decide for yourself. If you still feel I was out of line, then I offer my apologies.

I think you may need to sync it manually…. are you doing that? Also, if you have multiple databases, are you syncing all of them?

Note, Bonjour doesn’t require manual syncing. It functions like any other sync method, though obviously you can manually sync with any of them as well.

At this very moment, I’m syncing between two Macs and an iPhone right now. But of course they’re all on, on the same network with no network prohibitions, and running DEVONthink or DEVONthink To Go. :slight_smile:

Good to know… I haven’t used it much, so I wasn’t 100% sure.

Figured it out. I had enabled Bonjour on my Mac and iPhone, but I didn’t realize I had to (on my phone) manually enable the database I wanted synced.

I’ve turned those on, and it’s already synched my 3 tiny databases, and it’s now working on my 1 giant database.

I just need to remember to open DTG while I’m home, to get everything synced.

When you say you “enabled Bonjour” on both devices, since you have it working you must have done it correctly, but for others reading this thread, only one device on the network should have Bonjour turned “on”. For me:

  • iMac with macOS I consider the “server” and I have “accept incoming connections” turn on as “available” in the Sync Setting panel, and “off” on MacBook
  • iPhone and iPad with iOS in “Settings”, Bonjour is turned “Off”

And yes (glad you found it), on iOS you have to turn the switch “on” for Bonjour in the Locations screen, and turn on/off your selection of databases to sync.

All this in the DEVONthink Manual.

1 Like

Treading gently here, I’ve started seeing these errors swarming in both DT3 and DTTG on two different devices.

Other than changing sync methods, or waiting for Apple to resolve the issue (or the issue to resolve itself), is there anything to be done?

Which versions of DEVONthink (To Go) do you use?

3.8.1 on iOS and also on iPadOS. DT 3.9.6 on an M2 laptop.

When I was attempting to use this, I noticed more issues when I had the private relay options enabled. Also, and I am not sure if this had anything to do with it, but I feel like it worked better when I had privacy settings on the adapter for IP tracking disabled… like so:

It’s been some time since I tested this, but hope this helps.

If any of this is based on work happening on Wednesday evening April 3rd, at around 6PM EST, a whole bunch of Apple services were offline or laggy for a few hours.
This looks fine now but it was all red and yellow during the time noted above.

I’m sure it has nothing to do with a global Microsoft outage that’s been going on to various degrees the day after. 100% sure, ok, maybe 95%…. well actually…how about 90%…etc.

1 Like

Thank you, both. I’ve turned off Limit IP address tracking, and we’ll see if that helps, though it hasn’t resolved the issue yet.

The issue indeed started around the mass outages at Apple, but even if they’ve turned everything off and back on again, sync via those services hasn’t yet resumed.

At some point I suppose I’ll have to explore moving other other sync options. Thanks again.

Have you rebooted?

I have rebooted all 3 devices, and alas the errors persist.

As far as I know iCloud uses (or at least used) not only Apple’s own servers but also Amazon AWS, Microsoft Azure and even Google. Therefore Microsoft’s outage might have been the reason for iCloud’s failure. And that’s IMHO the reason why the iCloud experience varies a lot.

1 Like

I started getting CKErrorDomain 15 on all my devices beginning April 2 at around 12:30 central time.

I have three seats of DT Pro on Macs and all are up to date latest macOS and DT. Additionally, an iPhone and an iPad. They are latest also.

What’s strange is that while none will sync, if I go into settings>sync>iCloud and “quickly verify database”, that operation performs and reports that that database appears OK. No CK errors. Same with verifying the location — no errors.

The DT log shows that it got a 500 error from the server. That indicates to me that the CloudKit endpoint on the Apple servers is failing somehow when it comes to sync only. Verifying works but not the sync itself.

A quick verification is not initating a full sync.
It’s more like shouting over a wall, “Hey! Do you have this one thing over there?”

A thorough verification is like sending a tax audit demand saying, “Please provide access to your accounting ledgers so i can go through them and make sure everything looks appropriate.” There’s more to be done by both parties in that situation.

1 Like

Understand- and I like the analogy. I just find it curious that some methods work without error. So the CK endpoint is functional or verify would fail also, right?

So it’s something to do with sync that the CK endpoint is choking on (and it’s not the connection to file stores or verify would choke also)