Tried to upgrade DT, now won't run!

I’m using a MacPro OS 10.6. When I opened DT today, I got a message stating that I could upgrade to the latest version. I clicked something about install and relaunch and expected I’d be up and running in no time. Instead DT quit. The icon now looks like an app that has just been downloaded from the Internet but never opened (a circle with a slanted line through it). When I double-click on the icon, I get this message:

“You can’t open the application Devothink because it may be damaged of incomplete.”

What should I do?


Try quitting the Sorter, if running, delete the app, and reinstall from a complete disk image from the DEVONthink downloads page.

Thanks, Greg! That seems to have worked. I was afraid things would be messed up, but they look normal. When I ran the new download it wanted to reinstall the OCR, plug-ins, etc. I wasn’t sure what to do, so I installed them again. For future reference, what is best?


Users report from time to time here the same experience that you have observed. I could be mistaken, but I suspect one possibility is that having the Sorter active could be the cause. I’d suggest quitting the Sorter before accepting the notice that an update is available. Reinstalling all the options won’t hurt a thing, although it does take additional time for DEVONthink to download and reinstall the Abbey software.

Thanks again, Greg!


See this relatively recent discussion:

Updating DTPO and new add-ons