Trouble downloading in 2.6.1, using iCloud

I have moved to iCloud and I’ve set that store location to “Always” download. But what I’m left with on individual files is the “ghost” image, with the blue Download x M/GB link underneath. When I tap that link, the cloud icon at the bottom progresses, but when it’s done, I’m left with the same ghost image and download link.

I’ve had this problem pre-2.6.1, but had “On Demand” selected, with the same result. I had hoped that changing that to “Always” would help, but no go.

With some seemingly random exceptions, It doesn’t seem to matter which database I’m in, or what kind of file I’m trying to download. I’ve gotten 1 plain text file and 1 pdf to appear so far.

Possible clue: Global Inbox isn’t synced: 1 item in DT2G, 13 in DDT Pro Office, and other numbers in (Trash, etc.) don’t match up, either.

I have a feeling there’s an obvious mistake or omission I am making, but I cannot figure out what it is.

Thanks for any help with this.

What sync location were you using previously and is it still enabled?

I was using Dropbox, and I have already disabled it.

If you were using Download Files: On demand with Dropbox, then disabled the Dropbox sync and switched to iCloud without downloading the content, there would be no contents to (1) download from Dropbox, and (2) nothing to upload to iCloud.

If you merely disabled the Dropbox sync location, you should…

  1. Disable any databases set in the iCloud sync location.
  2. Enable the Dropbox location again.
  3. Set a database to Download Files: Always in the Info popup for the database, and let it download the contents.
  4. After the contents are downloaded, disable the database in the Dropbox sync location.
  5. Enable that database in the iCloud sync location.
  6. If you want, you can set the database to Download Files: On demand (noting the settings of the Keep slider in DTTG’s Settings has an effect on this).
  7. Repeat from Step 3 with other databases.

When all this is done, you can disable the Dropbox location.

Thanks, this worked fine on iPad, and yes, it turned out I was correct in it being fairly obvious!

Still taking forever to sync on the iPhone, but I will just live with that. I don’t know why the iPad went so much quicker.

Thanks for your help.

You’re welcome. Have a good one!