trouble with evernote scripts


I am trying to get my evernote database onto DTPO, but having some problems. I tried to import the enex file, but DTPO tells me;

Systems event got an error: AppleEvent timed out

Then I tried the script from veritrope. I selected all notes in evernote, and ran the script. However, it only gets about 200 notes in and stops. It always stops at the same note. I have tried selecting notes below that one and running the script but it just does nothing. Does anyone have any ideas? Thanks,


I’d suggest contacting Justin at Veritrope, or tweeting him (@Veritrope). Justin is very helpful and I’m sure he would want to debug the script if there’s an error in it.

Ok, will do. Does anyone know what might be happening with the import enex script?

@korm - Thanks again! :smiley:

From your description, it sounds as if the AppleScript doesn’t like a particular note and so it halts. You should be able to tell which note it is by looking at the last note to arrive in DEVONthink.

Once you locate it, export it as an ENEX file and use the Bug Reporter to send it to me (along with your information). I’ll run it through my test set-up and see if I can figure out what the issue is!


Thanks Veritrope. I tried excluding the offending file, but every 10-20 notes its comes across another that leads to a halt in the process. Do you want me to send all of the problematic files or just a couple?


If you could send a few via the Bug Reporter link above, that would probably be enough to help me pinpoint the issue (crosses fingers)…


Quick Update:
I think the issue with certain notes halting the script has been resolved. The problem was that my site’s download links (which let you open the script directly in your script editor) were actually changing part of the script’s code.

I’m still waiting to hear back from Jonathon to confirm it works for him, but I’ve posted the updated code which works around the problem in case anyone else wants to take it for a spin!