Trouble with print to pdf script.

Most the scripts that are included with DevonThink work as expected. I have been trouble with the PDF printing script that is available in the print dialog box. I had been printing receipts from the web and email to the Web Receipts folder, but printing to DevonThink seems like it would be much handier.

When I select the script, first the script editor opens, then DevonThink opens if it is not open, then Safari opens, then I get an error message, then a dialog box appears saying that “Script Editor” cannot accept pdf files.

I would really like to get this working on my system. I am using 10.4.4 with DevonThink Pro 1.0.2. OmniWeb is my default browser.



[1] There was a glitch in how the “Save to DEVONthink Pro.scpt” script was saved. Let’s fix that. Locate the script at /Users/YourUserName/PDF Services/.

Now double-click on the script to open it under Script Editor. Press Command-S to save it to the same location. Quit Script editor.

[2] Using the script:

While viewing any printable document under any application, select File > Print.

In the Print panel, click on the PDF button and select “Save to DEVONthink Pro.scpt”.

Choose the group location to which the PDF should be saved in your DT Pro database.

That’s it.

Thanks a lot! I had the same problem - now it works :smiley:

Thank you. That was all it took.


Thanks, the script works - but the document is empty. When I save from Safari to the desktop, and then import, it is not empty. Any suggestions as to what may be going wrong here?

I should perhaps add that the empty file created in DT pro is bold & blue, thus a duplicate? But when I search for another file in DT, none I find.

Hi, smolk:

I’ve never seen that happen and can’t replicate it. Is this a new problem, i.e., did the script work properly for you in the past?

What OS version and DT Pro version are you using?

OS 10.4.6, DT Pro 1.1beta14.

The script has not been working for a long time, but that was for the reasons explained in this thread, I assume. But DT is not the only culprit. Sometimes in Safari with the Schubert Plugin, I get a blank file when trying to save it, unless I use alt + mouseclick > save as. But not always. So there must be some dfifference in the way the PDF is coded, or embedded? I’m just guessing, really. But it is the same type of behaviour.

The files I wanted to save to DT were journal articles to which I have access.


I assume you are using “Save to DEVONlthink Pro script.scpt” which is stored in ~/Library/PDF Services/.

Try moving that script to the Trash. Now, in DT Pro, select Help > Install Add-ons. Make certain that all the check boxes are checked and click on Install.

Return to ~/Library/PDF Services and confirm that the script has been newly installed.

Try again. While viewing a page or document in another application, select File > Print. When the Print panel appears, click on PDF. Select Save to DEVONthink Pro script.scpt.

Hope it works now.

Hi, your directions were clear so I was quite hopefiul, but alas, the purported PDF now does not import at all; the DT Log gives “failed” vor the Print Job.pdf. I was not asked to rename the file either.


The Schubert plugin isn’t necessary with OS X 10.4.6. You might try removing it if all else fails.

And if Adobe has installed a plugin for Reader or Acrobat Pro in your computer, either in your boot volume Library/Internet Plugins/ or in ~/Library/Internet Plugins/ delete it immediately. It causes problems with WebKit.

That particular script, named “Save to DEVONthink Pro script.scpt” should work in DT Pro 1.1.1 (the current version). To use it while viewing any printable document in any application, select File > Print. In the Print panel, click on the PDF button and choose the option named “Save to DEVONthink Pro script.scpt”. It will allow you to navigate to the group in which you wish to place the document.

If one is using the current version of DEVONthink Personal, no scripts work. But there is a way to capture PDF versions of any printable document into the DEVONthink PE database. Just drag an alias of your DEVONthink application into ~/Library/PDF Services/. Then when viewing a document under it’s parent application, select File > Print. When the Print panel appears, press the PDF button and select the alias of DEVONthink.

Thanks Bill, that does the trick, removing the Schubert PDF plugin (I did not delete the Schubert Word plugin, or is that unnecessary now as well?)

Many thanks for your attention.

No, that one is still necessary.