trouble with Save to DevonThink.Pro PDF script

In reverting a G4 to 10.4 from 10.5, moving files between users, changing permissions, etc., I seem to have disabled the “Save to DevonThink.Pro” PDF script. It appears in the the Print window menu and can be selected – but no DT folder dialog appears. Perhaps related: DT isn’t opening my “default” file.

Could these be permissions issues? If so, what permissions should be set for the script, etc.?


Check the permissions of the folder ~/Library/PDF Services (in your home folder) or just delete this folder and reinstall the scripts via Help > Install add-ons. In addition, you might have to set up a default database (see preferences or database properties) if you didn’t copy the preferences.

Christian – thanks. I deleted and reinstalled the scripts per your instructions. Now the script makes it through the “processing page xx” counter but still doesn’t show the folder dialog or write to the database.

I set up a test user; installed the scripts there; and everything works.

I adjusted permissions on the following in my primary user to match that in the test user:

For the Home folder, test.dtbase, the PDF Services folder, and the Save to DEVONthink Pro script:

[list]owner (me) RW
group (me) R
other R

For the user’s Desktop, Library folder, Preferences folder, DT and Safari plist files:

owner (me) RW
group (me) no access
other no access[/list:u]

Are those as they should be for the script to run properly?

Is there anything else I need to set?

(Re the default database: I was able to set it database through database properties, so that’s fixed.)

You could also delete the caches (~/Library/Caches) and the AppleScript preferences ( and check if this will make a difference.

Thanks again – but, alas, deleting caches didn’t help; and I didn’t have AppleScript preferences.

So, I opted to create another user, move all Document files and a few Library files, change ownership on those, fix permissions with DU, and leave the rest of the Library files behind.

All seems to be working fine so far.

Thanks again,

I just printed a receipt to an open DB from the Print dialog box and nothing happened. It went through the motions as if it was printing to PDF, but then I had to do the same thing and this time it prompted me for a folder location and it worked. Strange.

When you suggest default database (which I have set as an unrelated database to the one open), does that only mean if you want to print to DTP and there is no DB open?

The default database is only important if DEVONthink Pro isn’t yet running while executing this script. Without a default database the scripts activates DEVONthink Pro but should present an alert as there is no database.

Anyway, the PDF creation of Mac OS X is (at least up to Mac OS X 10.4.11, didn’t check this on Leopard) not that reliable and might fail every then and now. Trying it again usually solves the problem.

Thanks. I’m running Leopard.