Troubleshooting File->Update Indexed Items

I am in need of some guidance in re: updating indexed folders and files.

I have indexed a Folder which has a total of 470 files and sub-folders in it. All of the files and sub-folders were included in the original index.

I attached the synchronize.scpt, but that does not update the index. I have tried updating the index manually through the menu.

So far none of the new files or sub-folders that have been added to the HDD are being indexed and reflected in DTPO.

Any ideas of where I need to go with this?

In the database, select the group that corresponds to that external folder in the Finder. If, e.g., you used the menubar command ‘File > Index’ to Index-capture the external folder, the group should have a ‘hooked arrow’ symbol to the right of the group Name in a database view window.

If that group does indeed show the Indexed symbol, attaching the Synchronize script to it (in the Info panel) or manually selecting the group and invoking ‘File > Update indexed items’ on the group should result in updating the Indexed content. Note that if the ‘Synchronize’ script was attached to the group, the updating doesn’t take place until it is next selected/opened.

But if the external folder had been copied (Import-captured) into the database, the corresponding group isn’t Index-captured and cannot be updated to changes in the external folder.

I am having a similar problem. I cannot update the indexes in existing groups in a db. They hooked arrow is displayed and they HAVE updated in the past but now, nothing new added the file system will show up after manually indexing. I can create a new index to the same folder and it works (for a while).

Getting frustrating as I can’t count on it working. Pls advise.

The Paths to the external files/folders can be broken by renaming or moving the external files/folders that were Index-captured. That’s one possibility.

Another possibility is database damage. Check for possible errors using Tools > Verify & Repair.

Reorganizing the Indexed content in the database can cause complexities, including making it difficult in some cases to detect updates, even if they were made. If you have Indexed content in a database, it’s prudent to leave the organization of that material just as it is in the external items, except that it’s OK to replicate Indexed documents or groups to other locations in the database.

If all the Indexed items in the Finder are contained within a single folder, any changes to that folder can be updated by invoking the ‘Update Indexed items’ command on the corresponding group in the database. But it multiple folders at the same or different levels in the Finder hierarchy have been Indexed, the ‘Update’ command would have to be invoked in multiple instances, as each Index capture was a separate action involving different Index transactions.

Here is the scenario:

I have an indexed folder in my db, call it Client1.
In Finder, I go to the Client1 folder and add a new subfolder, call it 2012Correspondence and add a few docs.
In DTP, it doesn’t show up after I re-index.

This defeats the purpose of indexing for my usage if this is problematic. DB checks out fine for errors.

I created a test scenario as you described. When I then selected the group named Client1 in the database and invoked ‘update indexed items’, any and all changes to the external folder named Client1 were displayed in the database. The database displayed a subgroup named 2012Correspondence, with contents.

I’ve never encountered a failure of updating Indexed items, unless the Paths to the Indexed items became invalid - in which case the items become missing in the database.

Could you please create a new, small database that illustrates your case, and test the results? If you find that updating isn’t taking place, close the test database, make a zipped copy in the Finder and attach it to a message to Support, including a link to this user forum thread.

Could the use of FileVault2 be causing problems?

This scenario is exactly like the problem I’ve been having. In my case I have a folder ~\Documents\Biblical and Theological Studies\Ecclesiology which had been previously indexed by DTPO. Later I added a sub-folder entitled ~\Missional Church and dropped two files into it.

When I selected File->Update Indexed Items DTPO did not sniff out the new sub-folder nor the two files therein. After trying several fixes I ended up deleting the index in DTPO (being careful to avoid deleting any files!) and creating a new index.

So in my experience this is still an issue.

Yes. . something is going on.

And to the moderator or tech support, I can’t send you the folders/files as they contain confidential client data.

Just to clarify to anyone experiencing this, you must first select the indexed group to make it active before executing the menu command ‘File>Update Indexed Items’. If you have more than one indexed group-you must select each indexed group and run the command, which is why attaching the synchronize script works better for most. Just executing the command will not force DEVONthink to update multiple indexed groups across databases.

FWIW, the indexed groups function of DEVONthink has been 100% reliable for me during many years of use.

Perhaps this was the source of the problem - pilot error! I have tried it out several times, making sure each time to select the indexed group so it is highlighted. Now it’s working like a charm.

Thanks for being patient with the noobs!

I know this is an old thread but this info might be useful (using DTP Office 2.8.9).

I discovered that if I index a folder, then delete one of the files in the folder from the index in DTP (i.e. the file is still out in the folder on the hard drive), then select the folder in DTP and invoke the File -> Update Indexed Items command, then the file you previously deleted from the index in DTP is NOT re-indexed. I suspect this behavior is intended.

I also discovered that if you move the “deleted” file out of the folder and then back into the folder, it’s still not picked up by DTP.

In other words, if you manually “delete” an indexed file/folder from within DTP, you will have to manually re-add it via File -> Index… to get it back into DTP.

I’m not sure if you’re emptying the Trash after deleting the file in DEVONthink, but if you empty the Trash, subsequent updates will reindex the file.

Updating indexed files is defo not working for me. I’ve got my Bookends Attachments folder indexed freshly. I add a file to that folder. In DT3 I click on the same group and then Update Indexed Files and Folders. Nothing happens.

Did you already check to see if the indexed group in DEVONthink has already updated? The integration with the filesystem is much tighter than in DEVONthink 2.

Unfortunently it isn’t


Where is your Bookends Attachments folder?

Hi. I only just saw this. Thanks anyhow! :slight_smile:

No worries! :slight_smile:

Hi I’m having the same problem. I’ve indexed a one drive folder on my computer, which worked fine. Now I’ve added 5 pdfs to that one drive folder and the index in DT3 is not updating. It still shows that no pdfs were added. I’ve tried “Update Indexed Items” but nothing happens…