Trying to undo encryption on database

A few weeks ago, in the course of trying to extract myself from severe sync problems, I encrypted my database. I would like now to undo the encryption–it has led to problems with limited disk space on my laptop. Is there a way to do this? Ought I to recreate the database with different properties? (I know I’ve recreated my database in the past, but I don’t remember how, and I never had to deal with encryption.)

I am looking through the forums and Help and various manuals and (maybe because I am feeling frantic) not seeing any advice.

I think I’ve solved this by copying the contents of the encrypted database into a new, unencrypted one. Now to see if the sync problems reappear.

Copying (or moving) the contents into a new, unencrypted database is indeed the easiest solution. But there’s another possibility:

  1. Change the extension in the Finder to .sparseimage
  2. Mount the disk image
  3. Move the .dtBase2 database from the mounted disk image e.g. to the desktop
  4. Unmount the volume

Thank you for this advice, cgrunenberg. It looks as if the mounted .sparseimage folder contains mostly .dtMeta files and no .dtBase2 database. So clearly I have done something wrong. But as I retrieved my database last night (minus the contents of its most recent Inbox) by copying its contents, I should not now need it retrieved by image mounting as well–I tried that just to see how it worked.

A screenshot would be very useful of the Finder’s view showing the mounted sparse image - thank you!