Typing stops all the time. Impossible to write longer texts

The last week I have encountred something DTpro for the first time really as a problem. If I write in normal speed the letters don’t appear on the screen while typing after a while.

I have recently updated and is now working on v. 1.02 beta 1.

I have tried to throw away preferences. 2 times
Verified and optimised 2 times
Rebuild the entirer database also 2 times. So far no success.

Is it to big? 1.92 GB is the size of my database.

Leif :unamused:

Try one of the free or shareware utilities to delete your user and system caches. Also run the system maintainance/cron tasks.

I’ve had similar issues and those two actions seemed to work for me.

TigerCacheCleaner is good (not free)

YASU is free and quite good as well.


Other suspects for anomalous behaviors include utilities such as TypeIt4Me and various haxies – especially outdated haxies.

TypeIt4Me is something that I never heard about, even less used. But what is “haxies”…?



Haxies are programs that change the behavior or appearance of Mac OS X, such as Application Enhancer. It’s possible for haxies to “mess up” memory space used by DT/DT Pro and cause problems.

Thanks. Hacks & MacOSX - I understand. Now I don’t use them at all. But I have tried YASU (because my old version of Cocktail and Macaroni did not make it) and have just restarted. Let us see how it will work out.


:unamused: :unamused: NO - Yasu and similar processes did not help

HELP that is really what I need.

First: This phenomenon only occurs in DT pro on this level. While writing this text for instance in Safari. There is a minmal, really small tendency to be a little bit slow. But this is ocean from the behavior of DT pro

Second: It is really bad. I can type 14 letters in a row and then the machine get stuck for a brief moment, and then more or less throws out the letters I have been writing while the machine got stuck. Then this process continues but now not with 14 letters first that works fine, but perhaps 6 letters

Three. It does not matters at all if I write Formatted or unformatted or I apply a certain style

Four: I have
Changed preferences
Used Coctail (old) to make the machiner work better, as well as Macaroni (same thing I guess - also old)
and then I have used a newly downloaded YASU

What can have made DT behave in this way. It feels like there is some kind of Cache that is supposed to be Wide and that is reduced to a minimal size…

HELP Leif Mohlin leif_ivan@mac.com


Next time this happens, try changing to a different font in the document. To do this, select All the text, press Command-T to invoke the Fonts panel, and select a different font.

Does that make a difference?

Sorry not to have a quick answer, but I do a lot of writing in DT Pro and haven’t encountered your problem.

I have experienced similar behaviour (although maybe not quite as severe) in other applications but not in DT so my feeling is that is an OS X issue of some kind. I am currently in search of a solution.

Another systemic approach but try using fontbook (IIRC) to check for corrupt fonts (and delete them, if you have no specific need).