Unable to export database archive

I have an encrypted database that I keep important documents in. Anytime I add to it, I like to export an archived copy to a separate hard drive.

This morning I added two emails to it. When I went to “Verify and Repair” before archiving, the log said “Files doesn’t have a checksum yet.”. I close and reopened the database, problem solved.

I next did a “Check File Integrity”. Log show success.

When I try to export, I get “Optimization of database failed.”

Ran through verify and check again, both good.

But Optimate and Rebuild are both grayed out.
Screenshot 2023-07-19 at 5.07.02 AM

Is there enough space in your database and on your disk?

Yes plenty

Encrypted databases reside in a macOS disk image. Does this image holding the database have sufficient space? That space is independent of your entire disk space availability. Probably some spare/overhead space is required–how much, I don’t know.

The DEVONthink Manual has information about encrypted databases which might be useful.

After rebooting, it worked as normal again.

1 Like