Unable to start DTPO2

After updating to macOSX 10.14.5-beta (18F127a), yes I know beta, several weird things happened.
Starting DT3, adding my things and exited DT3. After some time, opening DT3 again and nothing happened. The initial screen was blinking for a second than disappeared and after that it was impossible to open anything in DT3. Trying DTPO2 and it starts, but goes into a request for my license. Entering license info will not allow me to register and, thus, there is no way to reach my databases.

After a couple of hours, DT3 starts to work again and I can get into all my databases and everything looks normal (and correct).

Starting DTPO2 still gives me the registration pane and entering my registration data and license still will not allow me to activate the registration button. This behaviour is repeated on both my iMac and MacBook Air.

Which version of DEVONthink Pro Office do you use and which edition of version 3 did you buy?

Similar thing just happened to me. DT2 wouldn’t respond to my DT2 license code so I tried the DT3 license code and—voila—it worked. Have you tried both?


Thanks for this tip. Yes, it works to use DT3 registration code to log in to (old) DTPO2 system. Works on both my macs.