Unable to use full-text search with DTTG

Hi,

I have a database with a list of images, with names like “IMG_0001.JPEG”, “IMG_0138.CR2” and so on.

However, full text search just does not work at all.

I tried searching for “extension:JPEG”, which on my Mac would return all the JPEG files in the database. “extension:JPEG” returned nothing on both on my phone and iPad.

I tried to search for a specific file, let’s say “IMG_0192.JPEG”. “*192*”, “192”, “*192”, and “192*” returned nothing on my phone and iPad.

I have tried reindexing on my mobile devices and even gone to creating a new database to check. Am I doing anything wrong?

Cheers

(All the search terms were without the quotes)

Update: it appears that “extension:JPEG” is working when the database download status is set to “always”. It still would not work when the database is set to “on demand” and the files are not downloaded. Is this expected behaviour?

That is correct. DEVONthink To Go does not have an item’s file name or path before it is actually downloaded. On the Mac this is less a problem because items are usually always downloaded.

That is a highly interesting limitation of shallow sync if I understand you correctly. At the same time the content of those files is indexed, though? Presumably by which ever device the file originated on. Would it be possible for that device to gather information re. the file name and dissipate it to other devices in the same way? Or am I misunderstanding the mechanics of sync…?

The file name is actually transferred in the sync data but is only stored for bookkeeping, not in a searchable way. We might change this in a future version and add the file name as a searchable field to the underlying database structure.

1 Like