Undo for Image Editor?

For me, undo isn’t available for image editing. Could that be added?


In my limited testing of Image Edit, undo is available. Is undo unavailable for everything you are doing in Image Edit? Also, what file type(s) are you working with?

The first time I tried editing an image, I’m pretty sure Undo was not available until I actually saved the changes. After that, I was able to undo each change.

I didn’t see it referenced in the manual, but it appears that edits are applied to images in the same way it works in iPhoto. That is, even after saving you can use the button on the Image Editor panel to reset the image to its original appearance.

By the way (feature request!), the image edit window would be more useful if numbers were used with the sliders. If I, accidently or otherwise, move the Gamma slider, I want to make sure I can get it back to 1.8.


I’m trying it on different jpgs (and none of them are locked).

Played with it some more, it seems that undo is unavailable for “effects.” It’s not greyed out if I adjust the exposure, but it doesn’t work consistently. Worked a couple of times and then stopped. I’m getting this error in the console:

DEVONthink Pro[2580] undo: NSUndoManager 0x1a6d3520 is in invalid state, undo was called with too many nested undo groups

I tried importing a new image to the database and still got that message in the console the first time I adjusted the exposure and tried Undo.

I’m still on Leopard 10.5.8, DTPO ver 2.0pb7.

I messed with it some more. The problem seems to occur after I apply “Effects”. So if I apply an “effect”, then adjust the exposure, then try to undo adjust exposure, I get the above console message.

Edit Again:
I messed with some more again. I can’t make it fail consistently. I’ll try some more.