Update Indexed Items sometimes doesn't do anything

I have in one database various folders on my machine which I index via DEVONthink.

One folder (an export from another program) is occasionally completely deleted and then recreated again via exporting from the other program.

When I afterwards click lUodare Indexed Items. nothing happens to the view of the folder in DEVONthink: It still shows the old ecport which was blown away a while ago.

Hhow can I really force reindexing my folder and how can I see this in DEVONthink’s UI?

What’s the path of the folder? Did you select the group in the main view or the sidebar?

The path of the folder is:


I tried both ways:


Selecting the folder in the main view:

then choosing File --> Update Indexed Items.


Selecting the folder in the side bar:

Screen Shot 2020-04-01 at 10.12.15 pm

then as well choosing File --> Update Indexed Items.

In any case the content in devonthink does not seem to update.

Is Calibre running at the same time? And should items actually be removed, added or updated?

Calibre is running at the same time, but it doesn’t write its library to ~/Dropbox/folder/calibre-books. The library is somewhere else.

This is just a flat export I do once day. (I.e. I delete the folder and run the export command which repopulates the folder.)

Then I trigger in DEVONthink the Update Indexed Items (and Tags -> Convert Keywords).

This is not the same path as what you posted above.

Screenshot of Safari (4-1-20, 8-59-58 AM)

Sorry that was just a typo. I meant ~/Dropbox/read/calibre-books.

The way I fixed it is *in DEVONthink I deleted the indexed folder calibre-books from the parent group Dropbox, and added the directory on disk again as Indexed Folder.

Now it looks right:

(Note the much smaller item count - That corresponds with the directory on the filesystem.)

However I’m worrierd the next time the folder changes DEVONthink again doesn’t pick it up. Can I automate the “delete and re-add” procedure in DEVONthink?

Why are you deleting and recreating the folder in the Finder?

Are you running in a Fusion Drive or have Parallels installed or both?

That’s what the export procedure does. Is it a problem to index a folder which is recreated now and then?

Neither Fusion Drive and nor Parallels.

I have same issue you have (plus other nasty issues with duplicates) in one machine from my 3 machines, and the only difference between the 2 that work fine and the one that fails is that: fusion drive AND Parallels.

For the DEVONthink team: Is there any problen with an Indexed folder which now and then is complete rebuilt?

How do you want to exactly rebuild it?

Why aren’t you just dragging and dropping from Calibre to the Dropbox folder?

I use a script which:

  1. deletes ~/Dropbox/read/calibre-books
  2. created an empty ~/Dropbox/read/calibre-books
  3. exports via calibredb export all formats of all books to a temp location
  4. moves from each book only one (preferred) format to ~/Dropbox/read/calibre-books
  5. deletes the temp location.

This script is triggered once a day at 5:15am on my iMac (which runs calibre and DEVONthink).

Afterwards I would like to trigger in DEVONthink (via Applescript?):

A. a reindex of ~/Dropbox/read/calibre-books
B. a Convert Keywords to Tags action on this folder.

I still would need to delete the folder first to get rid of the old export and doing this manually is pretty cumbersome if you have a script which can do it for you. :smiley:

Your script appears to be reproducing an inefficient method of dealing with the files. Why are you doing a full export of all the books daily?

True, but calibre has no way to export automatically only the changed and new books, so I have to export all. :rofl:

Anyway, I don’t think that’s the problem here: The problem seems to be that a directory which is indexed doesn’t seem to update properly when it is recreated (i.e. briefly deleted and then created again).