Upgraded to Monterey and only my inbox is showing items

I upgraded to Monterey and all my databases, smart groups etc does not appear.

After I upgraded I tried to install the mail plug-in and Devonthink froze. I had to force quit it.

I do not know if everything was missing just from the Monterey update or after the force quit.

:worried:

If you could be a little more precise, it’d be easier to help you :slight_smile:

  • where are your databases located (e.g. /Users/yourusername/Databases)? Are the databases still there?
  • if the answer to the first question is yes, what is the file ending of the databases?
  • Are we talking global smart groups or ones located in databases?

Yes

dtBase2

global smart groups and smart rules

Thank you for your interest and time in helping me.

1 Like

Ok, so if the databases are still there, then all is good - you can open them from Finder.

What size and modified date is the following file: /Users/yourusername/Library/Application Support/DEVONthink 3/SmartGroups.plist?

Is anything else “missing” - smart rules, preferences…?

16,536 bytes (20 KB on disk)

October 24, 2021 at 1:18 PM

  • smart rules are missing

  • preferences looks like its there

my custom metadata is still there

Ok, so the data on the smart groups is actually still there too. Before we continue, have you tried restarting your Mac? I ask, because if the databases are where they should be, and the information which DT relies on is also available, then it sounds like DT isn’t using it. Ah, does DT have Full Disk Access? (System Preferences/Security & Privacy/Full Disk Access)

It does have full disk access.

I am restarting my mac now.

Did the reboot and still the same.

I would make a backup copy of /Users/yourusername/Library/Application Support/DEVONthink 3 before continuing.

When you say the databases are missing, what do you mean? Do you mean the favourites are no longer there, or the list of recently opened databases…? If you open a database from the Finder (by selecting Open from the context menu of the database in Finder), what happens?

Also, if you try to open /Users/yourusername/Library/Application Support/DEVONthink 3/SmartGroups.plist with e.g. TextEdit, does it open (don’t edit it)?

  • the list of recently opened databases is empty

  • I selected one database and it opened ok looks like everything is there in the database

I opened it in bbedit and it opened.
copied a dictionary from it.

	<dict>
		<key>data</key>
		<data>
		AAAAAAABAAH///8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
		AAAAAP////////8AAFhUUkEhAP////8B//8AAAAAAAAAEP//AP8A/wAAAAD/
		/wAAAAD/U0JTRwAAALQAAAAAAD8AAP///wAAAAAAAAAAAAAAAAAAAAAAAAAA
		AAAAAAAAAAAAAAAAAAAAAAAA/////////wAAWFRSQSEA/////wH//wAAAAAA
		AAAA//8A/wD/AAAAAP//AAAAAP9TR0RUAAAABIMKQQ+kAAAAAABBD6QAAAAA
		AIAKQQ+kAAAAAABBD6QAAAAAAIEKQQ+kAAAAAABBD6QAAAAAAIIKQQ+kAAAA
		AABBD6QAAAAAAEtTVFBLU1RQ
		</data>
		<key>name</key>
		<string>☺︎ Folder - Worked in Last 3 Days</string>
		<key>settings</key>
		<dict>
			<key>BrowserView</key>
			<integer>0</integer>
			<key>DetailedIconView</key>
			<false/>
			<key>PreviewMode</key>
			<integer>1</integer>
			<key>ReverseSorting</key>
			<true/>
			<key>Sorting</key>
			<integer>4</integer>
			<key>ThumbSize</key>
			<real>136</real>
		</dict>
		<key>sync</key>
		<dict>
			<key>UUID</key>
			<string>i blanked this out</string>
			<key>date</key>
			<date>2020-11-23T21:03:25Z</date>
		</dict>
	</dict>
	<dict>```

Ok, so that’s bizarr. Just to check: the sections (smart groups) are open? So if you hover over the words Smart Groups in the side bar, you get an arrow pointing down, not to the right?

Screenshot 2021-12-15 at 23.32.16

Oh my gosh, :open_mouth: I’m so embarrassed to say the least.

I am certain that I clicked it before to get the down arrow. Maybe that was before I rebooted.

Be as it may, everything is back and the only thing that is missing is my self respect.

Much appreciation for your time and help.

Thanks again.

2 Likes

Ok, that’s great - I was just coming to the end of my wisdom :see_no_evil:

Anyway, don’t you worry - that’s the whole point of helping one another out - different people, different mindsets, different levels of tiredness, whatever - so we all get to have an idea the other didn’t have :slight_smile:

Look after yourself :slight_smile:

3 Likes

OK, all the best to you.

1 Like