URLs not auto-recognizing

In my rich text documents in DevonThink, I’m finding that URLs do not auto-recognize – in order to link out from them, I need to manually select the link as text, then ‘link’ it to the URL.

Is this the expected behavior? Seems really odd, if so. If they should be auto-recognizing, any thoughts on what I might be doing wrong?

Example in screenshot:

At the end of the URL, e.g. at right of “_diseases” add a “carriage return” key by pressing enter. That should make the RTF program recognise the URL. Then you can remove that extra line.

Thank you – I should’ve specified that I already tried that. It makes no difference.

Adding returns, and otherwise playing with the text to try to trick it into recognizing has not worked. The behavior is consistent across all my rich text documents, and regardless of things like that.

Do you have Preferences > Editing > Smart Links enabled?

Bingo. Thank you! I trawled preferences, but didn’t spot it. All set!

You’re welcome :slight_smile: