Web browser extensions

I am having problems with the Web browser extensions for both Safari and Chrome.

Safari -

Whatever shortcut I enter into the preference panel for the extension, I cannot get the extension to activate:

To get it to activate it is always necessary to click on the icon in the toolbar. Is this known problem?


For Chrome the shortcut does work but the shortcut is hardwired into the extension (⌃+⇧+C):

Is there no way of changing this?

I just tried in Safari on Yosemite and the ⌘⇧c shortcut worked.

Thanks for the response.

But for me, no shortcut works in Safari. Using 10.10.2 on two different types of mac, and both will not recognise a shortcut for the DevonThinkPro web extension.

Do you perhaps have the specific keypress sequences you’ve tried defined for other functions in the OS or a different app? “Shift-Cmd-whatever” is a common keypress sequence.

Does it work after disabling all other extensions?

Maybe your shortcuts are colliding with other functionality? Here, for example, the the possible shortcut ⌘⇧i creates a new email message with the link to the shown web page even though I assigned it to Clip to DEVONthink, too. What happens when a shortcut is activated that is connected to two different functions in an app, is up to the app itself (or just sort of random).