Web Clipping popping up on every page load in Safari 5.0.3

After an Apple software update I now find that the DevonThink clipping extension in Safari is popping up on every web page load. I disabled the shortcut but this had no effect. Overall I find the results from clipping problematic, but this latest problem makes the clipping tool useless.

I can’t replicate that on my Macs. It’s a glitch that appears with the “Clip to DEVONthink” Safari extension on some computers, apparently as a result of a software environment issue.

The developers are aware of the issue and will issue a future update to the Safari extension.

In the meantime, you can disable the extension in Safari Preferences.

Hi Bill,

I was hoping that the Safari extension glitch notated above would be fixed in the new maintenance release, but it appears it hasn’t. Is this still an issue that is planned to be addressed or should we look for other alternatives to that function. Thanks.

When you update to version 2.0.7 of your DEVONthink application and the “Install Add-Ons” routine runs, a new version 1.1 of Clip to DEVONthink is installed in Safari and Firefox.

I’ve never had the display glitch reported by some on any of my Macs.

In Safari, try clicking on the application name in the menubar, then choose “Empty Cache”. Restart the computer. Do you still have the display glitch?

FYI, I believe one person had success by uninstalling the extension, quitting Safari, and then reinstalling it from http://devon-technologies.com/download/extras.html. Can you give that a try and see if that resolves it?

I tried removing the Clip Extension, quitting Safari, restarting, reinstalling Clip Extension and I still get the Web Clipping popping up on every page (Safari 5.0.3). I love the Web Clipping idea but it is a hassle appearing on every page, having to hit Command W, then Command Tab to get back to Safari. Am turning it off until some better idea for dealing with this comes along.

I am one of those experiencing the DEVONthink extension appearing on every page load in Safari 5, and have tried reinstalling as suggested in this thread, without any resolution. Is an update to this extension which addresses this bug imminent?



I have the same problem in Safari 5.0.4, with DevonThink Pro Office 2.0.9. The various fixes don’t appear to work. However, the Web Clipper only does this on the initial window, not on any further windows, so I have been opening Safari, open a new window (cmd-N) and going on from there.

This only happens on my MacBook (10.6.6), not on my iMac. I’m just starting to learn how to use this program…

Hello all. FYI, I’ve reason to believe that I’ve fixed this for the next release of the extension, which should be coming soon alongside an upcoming minor release of DEVONthink.