Web Sharing and Bonjour

I have been able to get web sharing working well in both DTPO 1.5 and 2.0. both locally and over the Internet. My problem is, however, in both versions I can only login using the URL’s entered directly into Safari or clicked on in Preferences>Server. The DTPO servers cannot be seen under Bonjour services whether it’s in Finder, Safari, or Bonjour Browser. Other Bonjour services are showing up normally in all those programs. Any suggestions?

OS X 10.5.5 and Safari 3.1.2

Have you tried to restart your Mac to let Bonjour re-sync?


Thanks for getting back to me. I have been trying to troubleshoot this problem myself to either fix it or provide additional information to anyone who wants to help.

My set up is two Macs, a Mac Pro and a MacBook, and an iPhone, all behind an Airport Extreme N router. My Macs are running 10.5.5. I have multiple partitons set up on both computers to try different configurations and pre-test software before permanent installation.

I haven’t paid to much attention to DTPO web sharing until DTPO 2 came out. I installed it and set up the web sharing and discovered the Bonjour anomaly. I went to another partition and tried web sharing with DTPO 1.5.4 and got the same result.

Let me give you more details on how I configured my Web Sharing (using DTPO 1.5.4). Perhaps I am missing something here:

  1. DTPO Prefs: Bonjour Name = DTPO; Domain = Public IP; Port = 8080
  2. Airport Extreme Setup:
    -Enable NAT = Yes
    -Port Mapping:
    Choose a service = don’t change
    Public UDP = 8080
    Public TCP = 8080
    Private IP =
    Private UDP = 8080
    Private UDP = 8080
    Description = Airport Extreme
    Check Advertise globally using Bonjour
    Service Name = Web Server (Airport)
    Service type = http

With this setup, I can access DTPO using any of the URLs listed in the DTPO Server prefs either locally or over the web including with my iPhone. I cannot find the DTPO server however using Bonjour either from Safari, Finder, or Bonjour Browser. I have other devices which are Bonjour-enabled including a Netgear Readynas and a TiVo HD which all show up properly in Bonjour as do both my computers in the Shared section of the Finder.

So at this point I am really puzzled. I hope you can help to at least point me to different ideas to try. Last night I tried using Lighthouse which worked properly but still no Bonjour. Thanks for any help.

Well, I’m making some progress.

In the Airport Extreme Port Mapping panel, I changed the service type to “_http._tcp.” After this, the service showed up in both Safari Bonjour and in the Bonjour Browser.

CURRENT PROBLEM: The service now points to my Airport Extreme’s IP rather than my Mac’s IP. Clicking it in Safari takes me to "http://‘routername’.local.:‘portnumber’ and fails to open the page. I can still however access the DTPO server using the local IP or the Public IP. I checked my firewall settings they are set to allow all incoming traffic. I also double-checked the port numbers in both the router and DTPO locations and they are the same.

Any new ideas?