Webclipper Problem in Safari

Hi all- I’m new to the forum…

I have just upgraded to DT pro from personal. Personal worked fine- but with pro the webclipper button does not work, which is a real pain as I used it all the time. If I reinstall, first it does nothing, and if I close and open Safari, then it produces a huge error message in the browser (I’ve attached the start of it here). What the hell is going on here? I uninstalled the personal version before this as if I pressed the web clipper it just kept opening the personal version, when I wanted it to go to pro.

Any help greatly appreciated as it is doing my head in!
Screen Shot 2013-05-12 at 01.01.41.png

Some cruft is hanging on in your config for some reason. I suggest resetting Safari (Safari > Reset Safari). Close Safari and DEVONthink (just to be sure). Navigate to ~/Library/Safari/Extensions and manually delete Clip to DEVONthink.safariextz. Shut down the machine. Restart. Open DEVONthink and install the extension.

Please write back to let the forum know how that went.


Nope- did all that, did not work, just got the same screen with huge error message…

This suggests you haven’t uninstalled Personal. Have you done a Spotlight search for Personal to find the rogue app?

I am having the same problem and tried the same solution (delete), as well as deleting all traces of Devonthink / pro from my system. Any other suggestions?