What exactly happens when using Share menu's "Add to DEVONthink 3"?

I am a new user and excited about DEVONthink! Thanks for a remarkable tool!

When I select a file in my Downloads folder and then “Share” >" Add to DEVONthink 3", what exactly happens?

Is a copy of the file saved inside the DEVONthink database? If so, when I move the file from my Downloads folder to the Trash and then Empty the Trash, is the copy safe and secure inside the DEVONthink database?

The file is imported/copied.

Yes, the original can be removed/moved/renamed etc.

Welcome @RickWheat

Instead of using the Share menu for such a simple operation, Command-drag and drop the file into the database and it will be moved into the database, nicely and neatly.
The default drag and drop, i.e., without the Command key, will copy the file. Also a very useful option in many circumstances.

I thank you both for the explanation and the tips!


You’re very welcome :slight_smile:

Where does the file go? I’ve tried the “Add to DEVONthink 3” extension in the Share menu – and it launches DEVONthink 3 (if the program isn’t already open), but I can’t see anything else happening. When I search for the file by name, it doesn’t come up. It’s not in the Inbox, so far as I can see. is it imported/copied somewhere else?

Did you check the Today global smart group in the Navigate sidebar?

If so, is anything reported in Window > Log?

Nothing is in the Today global smart group. Nothing is reported in the Window > Log.

What app are you sharing from?

Notebook (version 4.4.7), by Zoho.

I’m not seeing an issue with sharing from that application, though the export is rudimentary…

A File > Export as PDF is a little better…

Okay, I can do the Export as PDF, which is workable (it doesn’t include the note header, but otherwise seems fine).

However, still not sure why the “Add to DEVONthink 3” isn’t working for me – I’m glad it is for you, even rudimentarily, but it isn’t for me. I use the extension, and don’t get an error message … there’s simply nothing there (or anywhere I can see). Hence the original question – where is such a file placed by DEVONthink 3? Might it be in a folder that I’m not checking? I would have assumed it went into the global inbox, but that doesn’t seem to be correct.

What’s DEVONthink’s Preferences > Import > Destination set to?

Global Inbox