What is the function of "DEVONaddress:" links in e-mails?

When viewing e-mails in the To and From headers there’s first a mailto: link and after that there’s a card icon with a “DEVONaddress” link with the same e-mailaddress target. Just curious: what’s the supposed function of this “DEVONaddress” link?

Where are you seeing this?

When hovering over the card icon right after a name in the From or To field it links to a “DEVONaddress:person@email.com” link

It’s a reference to the address book.

Which addressbook is that? From what I’ve seen before macOS contacts uses addressbook:// links. I’ve tried if it links to imported Contacts in DT, but that doesn’t seem to be the case - or maybe I’m doing something wrong (using both .vcf and addressbook:// like contacts)

The one of macOS. Our URL scheme is just a wrapper using the email address instead of the contact’s UUID (as contacts appearing to be identical do not necessarily have the same UUID, e.g. due to iCloud or migration issue or if the user created the contacts manually on different machines)

That sounds really useful. I can see indeed (with SwiftDefaultApps) that DEVONaddress is registered as a URL handler. But when launching a DEVONaddress URL nothing happens (only activating DT when launching the URL outside of DT). Is there anything needed to enable this?

Does DEVONthink 3 have access to the contacts (see System Preferences > Security & Privacy) and does a contact having this email address exist?

Yes - DT has access to contacts (and importing contacts works). And a contact with that e-mailaddress exists in macOS contacts (tried several address, but all with the same result)

Just tried this successfully, which macOS version do you use? Does a reboot fix this?

Works here (and a new discovery of the week about DEVONthink!).

I’m on macOS 12.3. Just rebooted, no apparent change. After some experimenting I found out it works reliably when I right-click and select “Open in DEVONthink 3”. It does not work with a single click on the card icon.

Double click work? Does for me.

@cgrunenberg : The single click works for me but it only opens Contacts to the last selected contact, not the specific address. However, if Contacts is already open, it will then open the specific card.

This is the same on Monterey 12.3 and Catalina 10.15.7.

Double click works - sometimes. Can’t see a direct pattern why it will / won’t work. Also sometimes double clicking opens up the .png ‘multi card.png’ attachment.

A screencast of this behavior could be useful

The next release will fix this.

1 Like