When I customise the ⌘N shortcut, it shows ⌘N against the default action as well

When I press ⌘N, I always want to create a new Markdown note. In the app-specific keyboard settings for DT3, I add a setting for ‘Markdown’, pointing to ⌘N.

(Aside: how do I specify the full menu path in Apple’s keyboard settings? Fortunately, there are no clashing items in this case, but that’s not always true…)

When I go to DT3, I see that ⌘N is now correctly showing against Data > New > Markdown Text — but it is also showing against Data > New > With Clipboard, even though it no longer performs this action.


I’m a bit confused by this, as I thought Cocoa handled all this by itself and the app developer didn’t have to do anything, so I’m not sure if this is a DT bug or a macOS bug. I’m running DT version 3.7.2 on macOS 10.14.6 (18G9323) — I’m running a 2010 Mac Pro, so can’t upgrade past Mojave.

That’s actually right, DEVONthink does neither show the shortcuts nor handle custom shortcuts on its own.

E.g. Data->New->Markdown Text

1 Like

To un-assign something which is assigned by the developer (such as ⌘N for Data > New > With Clipboard), I always just assign it to a long key combination that I’m unlikely to press by accident (e.g., cmd-opt-shift-ctrl-8). Maybe there’s a way to unassign a shortcut entirely, but I haven’t found it.

Ah, probably a Mojave bug, then. I doubt Apple is going to be particularly interested in fixing it at this point :grin:

Roll on the upgraded large iMacs…

Thanks — I was sure there was a way, but it seems to be very difficult to find using a search engine. Most articles don’t bother listing the method for specifying the full path.

1 Like

TBH, I still think this is a bug, as the default setting overrides mine unless I also specify a shortcut for Data->New->With Clipboard. And there’s no option to specify “delete shortcut”, so I have to assign something to it. I’d rather have an option in the DT3 preferences which lets me specify which action should be assigned to ⌘N.

Additionally, it doesn’t do the right thing in any case — when I report a missed rubbish collection on my local council’s website, I copy the reference number from the page. Data->New->With Clipboard doesn’t give me a Markdown note containing just the reference number, it gives me an HTML document containing the reference number with all its HTML styling, which I don’t need. It then sets the document’s title to this:

<meta charset='utf-8'><span style="color: rgb(11, 12, 12); font-family: nta; font-size: 19px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-inden

Surely it should use an HTML document’s text to generate the title, not the raw source?