Where Is My File?

New paid-up DevonThink Personal user here – I downloaded the 2.0.6 upgrade and re-entered my license number – no problem. But I can’t find the large research project I created on DevonThink using the previous version. In other words, when I used to start DT my project would open automatically. Now that I’ve upgraded the project doesn’t appear and I don’t know where to find it. I looked in USER>LIBRARY>APPLICATION SUPPORT>DEVONTHINK but couldn’t find it there. Does this question make sense? If so, how can I locate the data file/project I created?

I guess what I’m asking is, How does file management work in DT? Can you create and save multiple projects/files in DT, like Word docs in MS Word? I don’t recall “saving” the only project I’ve worked on in DT – it was just there when I opened the app. But now no longer is.

Was the previous version 1.x or 2.0.x?

It was 2.0.x – I’ve kept up with all the DT updates.

An update from 2.0.x to 2.0.6 shouldn’t have any impact on the database which should be located in the folder ~/Library/Application Support/DEVONthink 2. Does Tools > Verify & Repair report any issues?

An update from 2.0.x to 2.0.6 also should not require that you re-enter your license info. Did you by chance delete the old version, and possibly your database along with it, before downloading and installing 2.0.6?

I assume I did. The only DT I have is the current version.

The last several auto-updates I’ve tried to install have all failed during the update process for some reason. Time before last, I emailed Tech Support and they had me download the updated version and install it, and it kept my project intact. This time (2.0.6) I had the same auto-install crash and thought I was doing what I did the previous time – download the updated version from the web site. I assumed when I opened the updated version if would “find” my registration info, etc., but it didn’t. Fortunately, I still had my license-purchase number so I re-entered it, but my previous work was not to be found.

I assume I deleted the previous DT folder with the prior version. Does that mean I deleted my project? Does the project data “live” in the app itself? I assumed the data was stored elsewhere in the system, not in the app itself. So if I delete a DT app I also delete the project I created with that app?

The data of DEVONthink Personal 2 is stored in the folder ~/Library/Application Support/DEVONthink 2, not inside the application.

Finally, could you send the log of the “auto-install crash” (see ~/Library/Logs/CrashReporter) to cgrunenberg - at - devon-technologies.com? Thanks in advance!

Another thought to add to what Christian said is if you used a delete utility such as AppDelete to remove the old version of DEVONthink, it will also delete the database, preference files, and license info, which could explain why you had to re-enter the DEVONthink registration information.

There is nothing in my DTP 2 folder in Application Support except a bunch of .dtMETA files, a Settings plist, templates, etc – no data file. I assume these files are from the recent install of 2.0.6.

Also, there’s nothing in the CrashReporter folder except a file dealing with Safari and GraphicConverter.

What Greg suggested may be the culprit. I just started using “Washing Machine” to clean extraneous files off my computer. Probably when I deleted the previous version of DT WashingMachine may have deleted the associated data files??

That’s really depressing - :frowning:

It’s at least the most likely explanation.