Which permissions for "Capture content from Firefox" clipper option?

Hey there,
When first installing DT3, I did not enable all the permissions when the app requested them (like enable access to webcam, to control Finder, etc.).

Now, I’d like to use the “Capture content from Firefox” option from the clipper. However, I get the following error when clicking on it:

I checked the permissions in System Preferences > Security & Privacy > Privacy, and DT is added and enabled under both “Accessibility” and “Full Disk Access”.
It also has the “Firefox” option enabled under “Automation”.

Is there any other option to enable? Any way to “reset” permissions so DT will ask for them again?


Welcome @julienma

This issue is with Firefox permissions and wouldn’t be resolved by resetting that. It’s currently under investigation if this is something we can overcome or a setting in Firefox. (You’ll notice a renewed focus on sandboxing in all major browsers right now.)

PS: Resetting macOS security permissions isn’t done by an application. It has to be done via Terminal commands, if it’s to be done at all. I’d suggest Googling tccutil with a word of caution, of course.


Do I understand correctly that there’s an issue with Clipper + FF in any case — not because I messed up with permissions initially? And so I’d better wait to see if your team can find a fix?

Or is it definitely an issue on my side, and so I should have a look at tccutil as suggested?

This should have nothing to do with the Security prefs or tccutil. I just mentioned the shell command in case you were looking to explore that outside this issue.

Yeah, it’s unclear if it’s a Sorter issue or a Firefox one. We’re looking into it. Thanks for your patience and understanding.

Ok, I understand. Thanks for the explanation!