Why can't I edit Markdown files?

Hi all. New DT user here.

According to the DEVONThink Blog (mail dot devontechnologies dot com/blog/tuesdaytipeditingoptionsindevonthink), “if a type of file can be edited in DEVONthink, it will open in a DEVONthink document window when the file is double-clicked.”

Having imported a bunch of markdown files from Ulysses.app, I find that when I double click on them, they open in DT, but any attempt to actually edit them produces nothing but a thunk sound.

Am I missing something here? Is there some setting that would allow me to edit these files, or must I convert these thousands of files into rtf or formatted note (not sure which is better) in order to make changes/apply styles?

Have a look at the four icons in the top right corner of your md file. Click on Source and you can edit.

1 Like

Thank you, @mbbntu! There are so many buttons and menu options here that I could have gone hours without finding the solution. Thank you thank you!!!

Quick follow-up question, if you don’t mind: is there a way to make source the default?

It’s not super hard to ⌃⌘X on a document, but if I have to do it hundreds of times a day it could get tedious.

No idea, I’m afraid, I have never had to do what you are trying. But you could batch convert all the files to .txt. You would lose the preview of the styling, but I’ve never found that a problem. I tend to have my markdown files with .txt extensions anyway.

DT > Preferences > Media and under Markdown Display change the dropdown from Preview Documents to Edit Documents (I think!).



And also Markdown is covered in Help > Documentation > Documents > Markdown.

1 Like

This is actually an old tip. Since version 3.0 the behaviour depends on the option Preferences > General > Double-click opens documents externally.

Yep. Stephen_C’s answer solved it for me, but thanks for the tip. :slight_smile: