wiki links: remove some instances, and "aliases" s

Hi all,

I’m just learning how to dive in the wiki linking world of DTP. And I have spent several hours through the thoughtful advice and comments posted all around here.

There are a couple of questions that I haven’t found answered yet, though…

  1. I’m using automatic wiki links, with Names and Aliases selected. However, sometimes in my entries there are words that turned on as linked, which should not be so. Is there a way to remove the link ONLY for those words, without having to turn off the “Automatic WikiLink” option?

  2. For those instances that I wanted a link for variants of a file name, I started using the “Aliases” field in the Info window. Does the “Aliases” field only accept single word link aliases? (so if I write more than one word there, will they become 2 different linking aliases?)

More about the second question, on linking aliases… Is it possible to allow more-than-one-word aliases via a syntax definition such as enclosing with quotes, “”, or square brackets, []? If that is not possible, could I request for such addition? (perhaps I have to create a new topic on the “Requests & Suggestions” forum). I read about wiki links having problems with apostrophes… perhaps this syntax option within aliases could solve this problem…

Thanks for any help on this.


Hi Mauricio,

This is not possible (as far as I know). The only thing is an option in preferences never to link to groups. I would agree that it would be a usefull feature for a future version to exclude certain documents or groups from being wiki-targets.

Just enter your aliases separated by commas. Multi word aliases work fine (even if a single word alias is within the phrase. DTP will use the longest hit for wiki-linking.)


Thanks for your reply Johannes!

I do believe that adding the possibility to remove selected wiki links on some words within the automatic linking mode would be very handy… Something like flagging the linked text with “do not link” or an action similar to the “learn spelling” in the dictionary should do the trick, I guess.


PS. Sorry if this reply appears twice… my internet connection kicked me out of session and I had to get back to the forum again…