With sincerest apologies: Updating Search DB for Word files after editing in Word

Hi all,

maybe it is just the late night. I just got DT and I am wondering: I understood, that unfortunately - as opposed to other DM-Systems I am used to, I cannot directly store data from MS word to DT, right? That is a nuisance but maybe one I can live with.

The other issue I have, however, is searching for content in Word docs once they have been changed. Maybe I am too stupid but I did not find anything (again the night is late indeed) and am wondering: I changed the settings so that the double click opens the file in word directly but (regardless of whether I imported the file or just indexed it and used the update function for indexed documents) the documents won’t show anymore after saving the changes. I tried by just adding a very specific word that I know I did not use elsewhere to be sure that I would find the very document I changed but nothing happens.

I hope that the problem is just sitting in front of the monitor between my very two ears and that this is just a short reply… :slight_smile:

Thank you and kind regards,


PS: The text shows in the Preview pane after some time but it is not indexed for the search…

After installing DT3 you should have a folder in the Mac Finder sidebar called “inbox”; that “inbox” is also available in the save-dialog in Word. That way you can save directly to DT3 - the file is placed in your global inbox. You can then move it where ever you want. When I open said file in Word from DT3, make changes (i.e. add the word “goramgagoo”) and then save it using command-S I can find that new content using DT3 search (ie the search index is updated correctly).

1 Like

In addition to Blanc’s fine response, on creation of the Word document file, save it to say “~/Desktop” and then with OSX’s Finder app, drag and drop it into DEVONthink where you want it. Then work on it (Opening/saving/etc) in Word to/from the DEVONthink database.

I used “database” word deliberately. DEVONthink is a “database”, not a file system.

And I confirm Blanc’s comment about searching it correct. DEVONthink search works great on Word files DOCX and DOC format, far as I can tell and experience.

On other approach, in addition to what @Blanc and @rmschne recommend. Over the years I’ve used DEVONthink, I’ve made it a practice to have lots of template starting points for Office and other document types, create the document I need as a blank in DEVONthink, and then open it from there in Word or PowerPoint, etc., for editing. All this approach is move what @blanc suggested to the front end of the process instead of the back end.

Neither approach is any more time consuming than creating documents in Word itself.

I also frequently use Office on Windows, so in that case I save the files to OneDrive and index the relevant OneDrive folders in DEVONthink on my MacBook.

1 Like

So, several suggestions as to possible work flows and two confirmations that search should work; so, why, I wonder, was it not working for you? @BLUEFROG may well weigh in here with a suggestion, but just wondering in the meantime - are you storing as docx, are you using DT3.0.4 (both are the conditions under which I just tested search), what size are your documents (does the same problem occur with a 3 word document)?

1 Like


thank you for the information. Yes, strangely the word search now works. Probably the program was still busy sifting through the other documents. And after deinstalling and reinstalling the sidebar, it now works, however, my Word is storing in the XML format and I only needed to find out, where to change that, which I did… Who had the stupid idea to introduce that format anyway? :wink:

Thank you very much!


1 Like

If you don’t like/want XML (and unless you have a special reason to use that format, I can’t think why you would), then in Word save in DOCX with the pull down “file format” control. Nothing to do with DEVONthink.

1 Like

Thanks, I just noticed that I had not finished by thought there. Maybe I need more sleep. XML is indeed completely unnecessary and I changed it in the word settings. Now it works perfect for me. Thank you for your help and quick responses!