word/.pdf files not importing

When I drag my files (word,.pdf) from desktop into a DT RTFD doc the ‘link’ sticks. But  then I try to launch them from DT, they do not.  Similarly, when I try to drag them back out to desktop, they don’t move to the desktop.  I am ‘copy files into database folder’-ing.  Just upgraded to 10.3 and DT 1.8, no problems before, problems now. Older DT RTFD docs I created still work (links and all) just fine.

Also, when the pdf imports as a link into RTFD it is now a fully scrollable window, which I don’t like at all- is there a way of just having it as a document link like the good old days- I prefer this much condensed way of having a link rather than a in-situ viewer.


I think I found the answer, so I’ll reply to my own question:

When attachments are dragged to the desktop from mac mail, word doc’s are saved as ‘read only’ and (apparently) cannot be pulled into DT as a link successfully. When dragged into a DT RTFD, they do not launch.  The trick is to open each document from the desktop, then save it to the desktop, then import the link into DT.  This seems to solve my problem- which was not a problem in pre-10.3 versions of OS X.  Rebuilding the DT database, and running Panther cache cleaner (PCC) did not do the trick.  

Any insight on keeping pdf imports a simple link (as opposed to the new scrollable pdf doc-within-a-doc) is still appreciated. I can’t spend any more of my day troubleshooting…  :)


Those scrollable PDF views inside RTFD documents are actually a new feature of Panther. Is there a common need to disable this feature? Or does anyone like this Panther feature (personally I don’t like it but I don’t attach PDF documents anyway)?

If I want to view a PDF file, I’d rather do that under Preview.

If I want to reference and link a PDF file inside an RTFD file, I’d like to see just the blue/underlined file name as a hyperlink (and not an icon).

So, I’d like the option to disable scrollable PDF links inside RTFD files.  :D

Will be disabled in v1.8.1 (no option :slight_smile:)

Good riddance, IMhO.