Wordservice does not work after 10.2.1 update

When I try to access one of WS services, either through the Service menu or a custom shortcut, I keep getting the following dialog: The services of this application are accessible via the Services menu [etc]" which is the same dialog as when I try to launch WS directly. At the same time I get an activity spike for syslogd, SandboxedServiceRunner and launchd (about 140%, 70% and 40% of CPU use). That version of Wordservices was installed from the App Store and it’s the latest version. I did not have a problem when the system was upgraded to sierra.

Let me know what you need to sort this issue.

I would delete it, download the free-world version from here: devontechnologies.com/redire … d=download, launch it once, and try it again. I am not seeing any issues here at all.

I have the same problem: WordService don’t work off the last update of macOS. I tried the to uninstall and install again without any progress. WordService still do not work. I use WordService a lot together with Devonthink pro office so I miss its functionality. Do you have any other possible solutions?
Kind regards Per

Uninstall and reinstall from the App Store or the free-world version?

I tried both: same bad result

What app are you trying it in?

I am having the same problem. After updating to 10.12.1, WordService doesn’t work in Keynote. I get the following error message:

The service I am trying to use (ALL CAPS) is activated in the Services panel.

I’m not seeing an issue in Keynote here. Remember that Services are dependent on the what the current app is reporting. Also, select your text and show the Services menu. Odds are, the service and shortcut will work after that in Keynote. (PS: The needing to load the Services menu - This would be an Apple issue.) :smiley:

Thanks Jim.

Not sure what you mean by “select your text and show the services menu”?

I think that’s what I’m doing. I select text, then invoke command-shift-U, which is a keyboard shortcut I set up for the “ALL CAPS” service.

I’ve also tried selecting the text and then going to Keynote > Services. The Services do show up there as expected, but when I select any of them I get the error message I posted.

They are all selected/activated in the Services area of System Preferences > Keyboard.

I would uninstall WordService, download the free-world version from here: devontechnologies.com/redire … d=download and reinstall it. I would also reboot the machine before I ran it, just as a good measure.

Thanks so much. How do I uninstall? Can’t find directions.

If it was installed via the App Store, open Launchpad (you can Spotlight search to open it). Then click and hold the WordService app until it starts shaking (a lá iOS). Click the X to uninstall it.
If there’s no X, it was a free-world install.


I uninstalled WordService and then downloaded the version you linked to. There are no installation instructions, so I tried double-clicking it. I got the exact same dialog box I posted a screenshot of earlier in the thread.

Am I not installing it correctly?

Opening it once should be all you need to do.

Something is definitely wrong, then. As I mentioned, when I tried to open it I get the same error message I posted earlier in the thread.

Are you saying that’s an issue with Apple rather than WordService? If so, I wonder how it’s possible that it’s working for you and not me?

Restarting the computer fixed a similar issue over here.