Workspaces Are Not Updating

Hi All,
I’ve been using the workspaces feature for a while and love it. Unfortunately, for the past month or two, it’s been consistently making the same error. When I am in a workspace and “update” it so it has a new layout according to its current configuration, it doesn’t save. The outcome is that when I use the shortcut key to open that workspace again, there is no record of the updated version. Instead, I see an earlier version of the workspace.
Any help would be appreciated.

1 Like

What OS are you running?

Just out of curiosity, if you update the workspace the quit DEVONthink, does it work as expected?

I’m using Ventura 13.0.1. My DEVONthink version is 3.8.6.

I just tried the update and close, but I’m getting the same result.


Thanks for the clarification.
Please hold the Option key and choose Help > Report bug to start a support ticket.

What exactly wasn’t updated? Basically workspaces just include opened databases, windows & tabs but not interface options like List view columns or sorting.

I’ll try to explain—I have subgroups labeled “01 Week, 02 Week, 03 Week…” as part of a parent group. Some of my workspaces focus on these parent groups. As the weeks go by, I update my workspaces to reflect the open groups appearing in my workspace. However, even after updating, when I open a workspace the groups that are open/expanded always revert back to earlier ones—and they’er not always the same. Does that make sense?

Workspaces don’t include the expansion of List views.

Ok. How is it that my groups appear in different states of expansion every time I trigger the “open group” hot key? I’m confused.

Which hotkey actually? The one of Go > To Group…?

Thanks for the reply. I’m using the workspace hotkey—they each have their own—the ones that can be found in this menu: Go > Workspaces.

Workspaces don’t retain the expansion, it should be last used one.

That would be lovely, but I’m not experiencing the last used expansion. Each time I open a workspace, I get group expansions from weeks or months ago. My recent open groups are always collapsed.

A screenshot before/after opening the workspace would be useful.