XMenu stopps working, stalls


#1

hi,

yesterday XMenu suddenly did not react to clicks anymore. No change after log-out/in or reboot (yes, it is a login-item).

I found out that it works again if I open it again manually. I´ll try to change it´s position to last among the login-items to see, if that helps.

When I wanted to use the built-in [Check For Updates]-command, it stalled. ???  After killing it from ActivityMonitor I could restart it again.

Greetings

          Thomas_U

XMenu 1.0a, OSX 10.3.2 (Build 7D24), G4 dual 867 MDD (silent with Verax-kit!), 1792 MB RAM


#2

Nope, I tried last and first and middle position: Only after I doubleclick the XMenu-app once more it displays the menu.  :-[

Greetings

          Thomas_U

XMenu 1.0a, OSX 10.3.2 (Build 7D24), G4 dual 867 MDD (silent with Verax-kit!), 1792 MB RAM


#3

Does OS X really launch XMenu during login (see Activity Monitor)? And is there enough room in the menubar for XMenu? Otherwise the icons of XMenu might be invisible (v1.1 will always place the icons on the right side of the menu bar).


#4

Bonjour,

good and obvious idea, exactly what I sought, but same problems than Thomas. After a firt launching, Xmenu stop functionning ; it is just possible to open it manuallly.

Michel

My Mac : Imac 700, OS 10.3.2, 640 Mo memory


#5

What kind of account do you use? Did you use a different account for the installation? Anything in the system console related to XMenu?


#6

No, I use only my administrator account. After some search in the console (console.log + system.log), I found only this :

   localhost diskarbitrationd[90]: disk1s2    hfs      3ECF582C-27F7-3E01-8128-6543F56FCF18 XMenu                   [not mounted]
localhost diskarbitrationd[90]: disk1s2    hfs      3ECF582C-27F7-3E01-8128-6543F56FCF18 XMenu                   /Volumes/XMenu

And nothing in the crash reporter

Michel


#7

Did you copy XMenu to the Applications folder and add the copied application to the startup items? Or did you add the XMenu application inside the disk image to the startup items? Because this can’t work and would explain the problem.


#8

Good Point. I checked by removing  XMenu from the Login-items and adding it again from it´s subfolder inside Utilities-Folder.

After Restart the problem remains.

And, sorry, I did not mention this in my first report: XMenu´s icon is there. And yes, it has enough space.

cu

    Thomas_U


#9

Admin-account.

No.

Console: Gar nix. Nada. Rien.

Also I have to add: A Click on the Dock-Icon does not start XMenu.

So my workaround for now is this:

Clock/hold Dock-Icon, [Show in Finder], double-click XMenu, Functionality is there!

OT: Tried  to record this as a script, but Script-Editor does not  record. Any clues anyone, why no recording?

cu

    Thomas_U


#10

I also am unable to activate XMenu from my laptop which is running version 10.11.6. It simply never starts working. But it appears to have been installed. See screenshot.

Perhaps XMenu.app does not support that operating system?

Thanks, Robert Tracy
rtracy@depaul.edu


#11

XMenu runs on 10.11.x. Are you not seeing the app in the menubar?


#12

The XMenu app appears in the Dock in the Applications folder, but not in the apps listed across the top of the screen.

I also downloaded and reinstalled the app, but starting it (from the download folder) doesn’t work.

Do I have to completely uninstall it first?

Thanks, rtracy@depaul.edu


#13

XMenu doesn’t show a dock icon when it’s running. It also should run fine from the Downloads folder (though it’s more appropriately installed in /Applications).