Yet again the problem of "File not yet available"

After setting one of my databases to sync on demand (via Dropbox and only with DTTG), I have 72 items that I cannot access or download. Either on the Mac or the iPad. Verify and Repair database doesn’t help.

Any idea on how to proceed?

Post-note: All the non-accessible items were created/imported in DT3, before I setup the sync.

  • Are the files indexed in DEVONthink?
  • Are the files missing?

Re: indexed. No, they were imported to the database.
Re: missing. The general view says the file is there, but like a “placeholder”… the “real” file cannot be downloaded (I suppose it’s in the Dropbox .dtCloud file, but I cannot access it).

Did you switch sync from iCloud to Dropbox?

Not recently. I’ve been on Dropbox sync for +5 months now. (I did try iCloud when DT3 came out, but settled on Dropbox soon.)

Any news on this?

According to the dates on the screenshot it might be possible that you migrated the sync store after adding these files. Did you create the sync store on the Mac or on iOS? Is anything logged to Windows > Log? And is a verification of the sync store successful?

I verified both ends of the .dtCloud (in the Mac and in the iPad). The behaviour of files is inconsistent. Some download upon demand to the iPad, some don’t. On the Mac none of them download.

This is definitely weird as this should work in both cases. Is anything logged (see Windows > Log on the Mac)? Does the iPad use another sync location too or also only the same Dropbox sync store?

Here’s the log:

I only have this .dtCloud (on Dropbox) on both ends.

What kind of files did you successfully download on the iPad but not on the Mac? Are they indexed or imported?

The process was a follows:

  1. Verified the synced database on DTTG (sync > location).
  2. Tried to download two pending files, one pdf, another a webarchive. Both downloaded.
  3. Tried to download the same files on DT3. No luck.
  4. Verified the synced database on DT3. Tried again to download any of the pending files. No luck.
  5. Tried to download any pending file on DTTG. This time, alas, no luck either.
  6. Repeated (1), followed by (2). No luck downloading any pending file. :frowning:

All the pending files were originally imported to DT3.

It’s hard to tell now whether this issue was caused by (an incomplete) migration. A warning should have been shown/logged in case of incomplete uploads at least. But you could try to use a second user account on the Mac, import the database from the sync store and check whether the files are there. If not then one option is to restore a backup (e.g. from Time Machine), in case of web content you could also download the items again (e.g. via Scripts > Download)

I think the easiest thing now will be downloading the contents again. I think that most files were not annotated, so it’s a bit of work but no real damage.

Still a drag, though.

Hi - one more observation adding to this and a workaround if just a small number of files is affected - I regularly (but rarely) encounter the issue that a pdf added to DTTG on my ipad is not available on the Mac (just the database entry, but not the file itself). I created a smart group (or was it there by default?) searching for entries “Objekt ist ausstehend” - should be “object is pending” in English. From time to time I check this group, identify pending files, go to DTTG, do a small edit in each of the pdfs on the ipad - and synching is immediately working. Doable for a small number of files. My synch works via NAS in my network at home, so maybe sync chokes under certain circumstances and needs a little nudge to start over.

1 Like

Which version of DEVONthink/DEVONthink To Go and of macOS/iOS do you use and what kind of sync location? And how do you add the PDF document exactly? Thanks in advance.

This has been with me for a while - always using latest version of DTTG, update to iOS 13 just done last week, so issues observed were under 12.x (always latest version). On my Mac it has been with me with DTPro 2.x and I recently found a couple ones in DT3, just updated to 3.5 last night - still running MacOS 10.14 - always latest version.

Sync is done via WebDav on Synology, recent model, latest OS versions. I sometimes connect to Synology via VPN on my DSL router to sync from remote locations (might be a factor, but not sure, usually seems to work well - with hiccups from time to time on DTTG side).

I usually add pdfs in iOS from Safari via “copy to DevonThink”.

It seems to me that the actual file is not available in sync store as manual download from Mac doesn’t work. So it seems that in some cases (I cannot specifiy) the actual file is not transferred from iPad to sync store, while the DB record is. This can be fixed (workaround that reliably works for me) by editing the pdf on iPad (e.g highlighting the title, removing the highlight after successful sync). Hope this helps, does sound like one of the things that are very difficult to pin down.

Thank you for the reply! Do you use the Pro package of DEVONthink To Go and are contents downloaded only on demand?

Pro Package, sync automatic, keep all, always load files, check transferred files (translating from German) - and to be precise: currently everything working fine!

If this should happen again then please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!