[2.0pb6] column, field editing, focus ring issues

Some misc. issues:

• Using View > Columns > … while editing a document field (e.g. started by tapping Tab) can cause the selected item to be incorrectly displayed. For example, adding the Comment column when editing the URL field resulted in this:

DTPO funky field display.png
And in one case (which I wasn’t able to reproduce) it was impossible to cancel the editing.

It might make sense for field editing to be implicitly canceled when adding/removing columns, like what happens when making a View > Sort > … submenu selection.

• When date columns (at least) are too narrow the text “wraps” in a peculiar way, e.g.:

Modified column - wrapped.png
Notice that the top of the time chars are subtly visible under the year. It’s more obvious when seen in multiple columns, e.g.:

Modified columns - wrapped.png
• When Tab is used to invoke field editing the field that’s selected can be unpredictable. In that first image above tapping Tab will usually start editing the URL field. And tapping Tab again (or Shift-Tab) doesn’t move to the next/previous field as expected; seems to cancel editing.

• The toolbar search field frequently has a focus ring without having input focus. I was noticing it disappear and reappear during the field editing tests above.

Intentionally posting in the Requests & Suggestion subforum, requesting/suggesting those issues be fixed. :slight_smile:


The next beta will do this but…

…I couldn’t reproduce those issues.

The first is consistently reproducible here by resizing the Modified column in List view, as seen in this short video clip:

DTPO - column width bug

And this screenshot shows the focus ring appearing around the toolbar search field with it deselected while a document in List view is selected:

Let me know if it might help to see a video clip of actions that’ll cause it to appear (and disappear) without the field ever having focus.

Btw, that’s on my iMac G5 running 10.5.8.

Thanks for the clip but still no luck. Do you use any extensions/haxies? The cursor doesn’t look like the one over here while resizing.

That might be useful.

I’ve got a few Input Managers installed, mostly Safari-related. None of that Candybar type UI-futzing stuff.

The “cursor” in the clip was the mouse click indicator from the Screenflick app.

I’ll make a focus ring clip after trying to reproduce that and the other problem under the Guest account.

If memory serves, I recall having this problem many releases ago in DTPO 1.x. Quick fix was to double-click the divider between columns. I’ve seen this in other column-oriented displays in Mac apps, and suspect it might be an Apple issue.

Presumably you haven’t seen and can’t reproduce it (by dragging the column divider) in DTPO 2.x?

Thanks for the suggestion, though it’s a no-op here. I can just adjust the column width until the text looks okay.

iTunes is the only app I use and know of that column divider double-clicking does something, typically resizing the column width to the largest item in it. Wish it worked like that in other apps when it’s a nuisance (re)adjusting column widths.

Since I couldn’t cause this or the focus ring problem to happen under the Guest account it seems related to something in my login environment. It may take awhile to further isolate it.

That might be true but version 2 uses a completely different code to display dates which is based on Apple’s examples actually :slight_smile:

I’ve isolated the cause for column resizing affecting the date/time display. It’s reproducible by changing List View Font under the General tab of Preferences to Lucida Grande 9 and even more dramatic with LG 10. Surely would happen with other fonts/sizes, too. It’s satisfying just knowing the reason even if it won’t be fixed soon/easily.

Still no luck over here. Might be specific to the dates and the system’s date formatters. However, the upcoming 2.0pb7 will make this a little bit more robust.

Thanks for trying again. I’ll retest here after resetting International Dates/Times Preferences, which I’d adjusted (under Guest, to match my regular login) thinking that might be the cause before later noticing the font difference mattered. Maybe it’s a combination of the two. Still a chance it could also be influenced by some third-party plugin(s)/extension(s) although disabling some of them before the other testing hadn’t mattered.

Reminder: this happens running 10.5.8; I don’t have a SL test environment to compare with.