3.0 Beta Bugs with custom metadata: display as columns in main window and more issues

I started using real data from 2.n to test 3.0. During the test, only 3.0 was opened. I created 5 custom metadata fields and updated the fields by about 40 batch processes using Tools>Batch Process in an index group that links to approx. 1000 docs (of which 800 are pdf) that are in iCloud. After the batch process, I rearranged the order of 5 custom metadata fields in Preference>Data to change the display order of the fields in the sidebar.

I tried to show the custom fields as columns in the main window. The first field I chose was “Journal Year”, and it displayed correctly, then I chose “Journal”. Instead of showing the column “Journal”, the wrong column of "Journal Type was shown. More strangely, column drop-down menu shown 3 columns were chosen. This behaviour is consistent in Preview settings of cmd-5, cmd-6, and cmd-7. However, only the column for “Journal” cannot be shown. Both “Journal Type” and “Journal” is a single-line text field. Note: as far as I can recall, I was able to display “Journal” as column after the fields were populated but not after the rearrangement of display order.

I tried to close and re-open 3.0, Empty Cache in 3.0, but the actions didn’t solve the issue. Tomorrow, I will create another single-line text custom metadata field to copy the same data from “Journal” and see this solution will work. But it seems clear that there is an issue with the column display (or my files? But the database works very well in 2.n for the last few years).

Please let me know if there are other ways for trouble shooting and thanks in advance.

One more issue:
I can’t add any additional custom metadata fields after adding 5 custom metadata fields with two, one, and no database opened. I guessed there might be a limit in the number of custom fields, I deleted a few default custom fields and tried again but still couldn’t add new custom metadata fields.

Please advise and thanks in advance

EDIT: After a very clean re-installation, the issues persist with the files in the index group. It seems the metadata fields are becoming sticky with the files. My next step is to restore the same folder from Finder by Time Machine.

Disclaimer: not expecting DT to solve my specific issue but only to report potential bugs. Custom metadata is a significant new feature so I hope it will run smoothly in next few beta updates.

I performed a clean installation of DT3 according to the help document, used time machine to restore the same index folder in Finder. The issues that are described in the message (1) and (2) of this topic seem gone, but two more random problems emerged.

(1) Update the custom metadata of a selection of multiple items directly from the inspector bar. The maximum number of items in a selection that can be updated at once is random and range from 3 to 20. This behaviour is not consistent.

(2) Sticky custom metadata. I found one of the custom fields I deleted re-appeared (not the problematic ones described in earlier messages). I tried to remove the field from Preference>Data a few times but failed. In a way that the field was removed in preference>data and disappeared from inspector bar, but re-appeared in the inspector bar after approx 1 min. Finally, I was able to delete the field by renaming it first.

EDIT1: For (2), the field re-appeared again after some time and with the original field name. I tried one more method and it worked. I emptied all data in that specific field before I deleted it again, and the deleted field is gone for good.

EDIT2: No, it doesn’t work. The sticky custom field re-appeared after 1 hr (longer) this time.

Did you duplicate definitions in Preferences > Data?

No. I create new fields.

BTW, (1) I found a new way to get rid of the sticky metadata fields: I changed the field type first, then I deleted it. Now it’s gone for 3 hours and not reappearing yet. (2) I am now able to create new field/s after I get rid of the sticky field.


In case that this should happen again then please send the file ~/Library/Application Support/DEVONthink 3/CustomMetaData.plist to cgrunenberg - at - devon-technologies.com - thanks!


Just FYI, I mentioned this in one other thread: pdf access in DT3 does seem more sluggish than in 2.n even for scrolling down the list and view document, more explicitly when some metadata fields are edited (such as url) before scrolling down to next item. If I move new pdf form inbox to a folder in one window while doing a search on the same folder in another window, it takes a sec or two to update the search. my pdf files are usually under 30 pages and mostly text only.

Which inspector is usually visible?

The Info bar with standard fields.

A screenshot of the full window might be useful but especially the Search & Concordance inspectors can cause delays.