A couple of sync issues

I’ve noticed two situations which keep recurring

For context,

  • I have two laptops, and one iPhone (so two copies of DT3 and one of DTTG)
  • I have the same set of DBs open at each
  • Workflow: (1) adding content from phone, (2) frequently adding notes from laptop-1, (3) occasionally accessing from laptop-2

Scenario-1: laptop-1 and laptop-2 are out of sync

I try to hit the Synchronize menu option, but don’t see any changes. More concretely, there is one group where I was adding sub-groups by dates and the view became “perfectly disjoint” between the two laptops, where new groups stayed on the laptops they were added at.

  • Note: this is more recent occurrence, and hopefully temporary, I’m not as bothered about it

Scenario-2: DTTG doesn’t “keep” some files

Every so often I’ll need to lookup something on my phone and I get the download button that never works. I just have to wait until I’m at my laptop. I’ve noticed this happens in a particular database more often than the rest (though that’s also the db one I “lookup” most frequently from my phone).

This is a longstanding occurrence, and quite annoying when it happens, and I don’t know what to do to fix it. I’ve tried deleting and re-installing DTTG, making sure my settings are set to keep everything, etc.

I know that it isn’t an “nothing’s working here” situation, because adding (clipping) content from my phone works, and shows up on my laptop (funny story, on laptop-2, but not laptop-1, but that’s a separate story)


To clarify, none of this dampens my enthusiasm for DT3 :slight_smile:, but if there are tips & tricks, especially for the “how do I force DTTG to keep content”

Good summary of the situation, but you have over-looked one key bit of information. What sync method do you use? Bonjour (on a local network) is probably the quickest and most reliable, but it can do only one device at a time. Even if on a remote service by another vendor, e.g. Apple, Dropbox, etc. time timing of the launch of the sync on DEVONthink ToGo is sort of up to Apple’s IOS, as I understand.

1 Like

I’m guessing here, but the appearance of a Download button on DTTG suggests to me that the OP is probably using On Demand downloading on the iOS device. Assuming that is true and they are accessing data on the move, that would make Bonjour rather less useful. I was wondering whether maybe the records the OP is trying to access aren’t actually available in the sync store yet and, as such, don’t download to the iOS device on demand. That makes your question all the more relevant, I feel - using a different sync store (e.g. CloudMe rather than iCloud) might make a difference.

1 Like
  • Is there anything reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it and tell me what it reports.

Hi. I’ve had longstanding sync issues (improved over the last couple of years), and though I don’t know the reason for sure, it would appear that Dropbox and DTTG are not playing well together in my case, perhaps because I have a lot of data (large numbers of files and 100 to 200GB of data). Whatever the cause, a solution I’ve found for groups with files in them that fail to download in a timely manner is to put them into a dummy database (I’ve labeled mine “sync database”) to trigger a sync. This works more times than not. Once I am back to my computer, I sort the files and groups into their appropriate locations.

  • No, I don’t see anything in Window → Log or the DTTG sync icon (earlier I did, and those turned out to be indexing errors etc, but this time there are persistent divergences in terms of some groups that simply don’t show up on other devices)

  • I can confirm that I’m not using “on-demand”, and when I do need to lookup, the phone isn’t near the laptop

  • I use iCloud for syncing, and I’d rather not move away from it if I can

  • The dummy database workaround is interesting, I will try it! (of course, this assumes that database is never out of sync :slight_smile:)

CloudKit (also an Apple product/service) offered by DEVONthink is purportedly better than the older iCloud. Still uses your iCloud account. Might try that.

If you are not using On Demand then it’s unclear to me where/why you are seeing a download button.

1 Like

Haha, yes it’s unclear to me why I’m seeing it too. I’ve tried deleting and re-installing DTTG in case some old settings are being persisted.

Yes, I’d switched from iCloud (legacy) to iCloud (CloudKit) when it was available, and all my databases are on that right now.

I can confirm the app preferences show Keep all and as a sanity check, the group’s “info” shows Always selected.

1 Like

So is the data available in the sync store, I wonder? Has it maybe failed to upload correctly… do you have enough space in iCloud available?

As you report you moved sync locations, take a look here Moving from iCloud to CloudKit syncing in case this rings any bells.

  • Do you have the database syncing to more than one active sync location?
    • If so, is one of the locations set to a shallow sync?

Yes, there are multiple locations (two DT3 and one DTTG). iOS is set to “keep all”.

I did see an error today, sharing screenshot:

What active sync locations do you have in DEVONthink To Go’s Settings > Sync: Locations ?

Here’s a screenshot:

I think @Bluefrog would also like one (maybe two) more screen shots. the one behind Settings → SYNC:Locations. Press on "iCloud (CloudKit) and post of screen shot of that also. While there, screen shot what’s under the “edit” button for your sync location.

Sure, here is the list of databases within iCloud and their status

OK. But I was thinking that the screen shot under the screen prior to the one shown above. Where in the upper right corner there is an “Edit” link. Shows the settings for the sync, e.g. masked key, how files are downloaded, etc. Just to save a bit of recycle time for @Bluefrog and give a complete picture.

And, if devices on local network, give Bonjour a try also. Can have both CloudKit and Bonjour running.

1 Like

Sorry I misunderstood earlier, here’s the relevant section:

1 Like

A big clue (though no answers yet): of the two laptops I have, one isn’t syncing (!)

This is what it looks like:

I checked the Log and it’s empty …

… any ideas? :frowning:

(Edit: restarted DT3 and now the one that was blocked on merging is unblocked :crossed_fingers:)