Abbyy OCR not working

Hey, I trying to figure out if anyone is having the same problem I am; I am running the latest version of Devonthink and have noticed that the OCR is not working. When I add a PDF to a database and click to make it searchable, DV tells me it’s adding the document, but then…hangs. I thought it was just the machine I was working on (Intel @ work), but today I’m working off my M1 and its doing the same thing.

I have tried it with multiple documents just to see if its the complexity of the document or something else, but it just seems to not work at all.

Any insight, suggestions or help would be greatly appreciated, I’m new to Devonthink.

CleanShot 2022-01-07 at 12.29.23

Devonthink 3.8
macOS Monterey 12.0.1 (Intel)
macOS Monterey 12.0.1 (M1)

Is Full Disk Access granted to DEVONthink?

Yes. I double checked, just to make sure.

1 Like

This could potentially be different problems on each device; you are currently at the M1 device if I understand correctly. Do you have Rosetta installed?

(And please allow me to suggest you check this thread.)

I think it may be helpful to deal with the Intel and M1-Macs separately initially. On the Intel Mac my first step would be to check Full Disk Access.

My intel Mac is my work computer. I’m home because we’re snowed in. After your suggestion though, I did look up Abbyy’s site and your right, it needs Rosetta which is not installed on my M1.

When I opened DV on the M1, it did not have full disk access, so I’m thinking that is probably the problem on my Intel.

Thank you thank you thank you. I will look at my work computer on Mon and update.

1 Like

Great - look after yourself and please let me know whether OCR works with Rosetta installed and/or FDA granted.

Abbyy does work under Rosetta, so THANK YOU for that!


1 Like

As the OCR engine is part of DEVONthink, I’m going to move this thread there (i.e., from Miscellaneous to DEVONthink) if you don’t mind. I think that may aid others in finding the solution at a later date if needs be.


Thank, again!

If your Intel Mac still has this issue when you try to OCR a document it could be that the OCR component has encountered a problem. The easiest way to reset it is to Quit DEVONthink and reboot your Mac. If problem persists please send a bug report by select the Help menu in DEVONthink, hold down the Option key and the last menu item should change to say “Report a bug”. This will generate an email with logs attached, mark for the attention of Alan in the email.

I just wanted to follow up and say that Full Disk Access was the problem" on my Intel machine. Once that was enabled, OCR worked as normal. Thanks again for your assistance!



Thanks for the follow-up :slight_smile: