Activating new Sync Plug In

I downloaded and followed the instructions associated with the plug in for syncing. Under the preference pane, there was no icon for syncing. I checked and supposedly have the up to date software. I double clicked on the plug in and it didn’t do anything other than open a dialog box which said:

Last login: Fri Dec 7 10:46:55 on ttys000
imacs-iMac:Sync.bundle imac$

Any ideas on how to get it to work? Thanks much

Quit DEVONthink and then reopen it.

Thanks I tried that. I see the icon now in the system preference pane but it gives me a message:

Could not load com.devon-technologies.DEVONthink.Sync.Preferences preference pane.

Sorry this isn’t working for you.

The instructions in the download of PB2 are correct and do work. Try again:

  1. Quit DEVONthink
  2. Navigate to ~/Library/Application Support/DEVONthink Pro 2/Plugins
  3. [size=85](NOTE: The “DEVONthink” folder name will vary per your edition of DEVONthink)[/size]
  4. Delete everything in Plugins – do NOT delete the folder
  5. Download and unzip PB2 from here
  6. Follow the instructions:

Thanks Korn for your help.

For whatever reason I don’t seem to have had the DevonThink Pro 2 or Plug in file in Application Support. I have a fully functioning version of DevonThink Pro 2 but don’t see those files in the Library. There is one file called “Proapps” but that doesn’t appear to be a Devon related file. I tried to create them and then tried to complete the procedure as described but that didn’t work. It gave me the same message I mentioned in my last post.

You are looking in the wrong place. The ProApps folder is located in the global Library/Application Support folder for your hard drive. The Application Support folder that you want is for the user account that you are logged in with. This is signified by the tilde symbol in the example path:

~/Library/Application Support/DEVONthink Pro 2/Plugins

where ‘~’ will be your user account name.

Greg, thanks but that does not seem to exist. I tried searching for it every which way and nothing comes up. I’m not the most computer savvy (as you can tell) but I normally don’t have problems figuring it out. I’m the only user of my computers so I don’t use the user profiles. --confused

It’s just not possible for DEVONthink to work (sync plugin or no sync plugin) if the folder Greg mentioned isn’t on your computer - so it has to be present:

~/Library/Application Support/DEVONthink Pro 2/

Since the beta is for experimentation - not for real data - you might want to pass on the beta test until a version of DEVONthink is released that automatically installs the plugin for you. Just a thought. :confused:

As korm mentioned, DEVONthink will not function without its folder in the user’s Application Support folder. I’m going to speculate that what you are unable to locate is the entire user library folder? If that’s the case, note that it is hidden by default in Mountain Lion. If you search the Web on “hidden library folder Mountain Lion”, you’ll find ways to make it visible.

Having said that, I would also agree with korm’s hint that you may want to wait on the release version of the sync plug-in. The sync technology is quite complex with many possibilities for something to go wrong-not for the faint of heart!

My Library folder was invisible. With the following command (in Terminal) you can see the folder:

defaults write AppleShowAllFiles TRUE;killall Finder

To hide the invisible folders again:

defaults write AppleShowAllFiles FALSE;killall Finder

You don’t have to use terminal to see the normally invisible Library folder temporarily.

Open a new finder window, then with the option key pressed, click on the the Go finder menu and select Library. Your Library folder will appear and you can navigate over to the correct folder, Library/Application Support/DevonThink Pro 2 (or your version).