Adding annotations not possible

Hi there,

when trying to add an annotation to a pdf-file, the annotation text disappears and is not saved, though a new record in the annotation folder is made (which is empty, too).

Anyone got an idea?
Thanks in advance!

Which version of DEVONthink do you use and how exactly did you add the annotation? E.g. did you use one of the default templates?

I use DT 3.7.2.
I add annotations using the field on the right side of the screen.


And do you just type the annotation?

Yes, I do.

So you enter text in the Annotations field of the Reminders & Annotations inspector?
Deselect and reselect the file. Is the text there still?

Yes, I do.
After deselecting and reselecting the text has disappeared, but there is an entry in the annotations folder named filename (annotation), but the file does not have any content.

  • What operating system are you running?
  • Does this persist after rebooting the machine?

MacOS Big Sur 11.4.
After rebooting the problem still persists.

Do you use any smart rules?

No, I don‘t use smart rules at all.

In the Annotations & Reminders inspector, click the Annotations dropdown and choose the New from Template > Default Annotation — Text. Type into it in the notes section. Then deselect and reselect the file. Is the text preserved?

That worked, thank you.
When I use markdown instead of Text, it does not work.

You’re welcome :slight_smile:
So the Default Annotation - Markdown doesn’t work for you?

Yes, the markdown annotations don‘t work here…

Does this also fail in a new database using a new PDF?

I haven‘t tried that yet. As soon as I did, I will let you know.

Thanks so far to all of you for helping me.

1 Like

I am also experiencing the exact same issue. However, for me even changing the default to Text doesn’t work. I am running latest Devonthink Pro and latest macOS Ventura. Instead of saving the annotation to the file, DTP creates an annotation file (as it is supposed to) in the ‘Annotations’ folder – but the annotation is not saved “in” the PDF file. It happens with both replicated and non-replicated files.

EDIT: Nevermind, I saw the suggestion too late to try a new database. That did the trick.