Adding Global inbox rule

I’ve set up a smart rule to always move any item from my Global Inbox to my database Inbox. For some reason this works fine unless I create the item in DTTG first, in which case the item isn’t moved. The rule is simple enough…


If I click on the smart rule in the sidebar, where it shows you the documents that the rule applies to, it shows nothing, despite having files still in the Global Inbox. If anyone can help me with this, that would be much appreciated.

The rule doesn’t have any conditions, adding e.g. Kind is Any Document should fix this.

I’d first add the condition Kind is Any Document.

And then I’d add the trigger Every Minute.

I would disagree with using this event trigger unless it’s actually necessary. If it’s not, you’re adding unnecessary overhead. Hourly would be a better general temporal option, if one is needed.

1 Like

Great, that did it, thank you.

It seems odd that it worked fine for files imported or created on the Mac, just not from DTTG. But it works now, which is all that matters. Cheers.

As we’ve often said, you should be as specific as possible when creating smart groups and smart rules. This way you are more certain to find or act on the intended files.

Like I wrote elsewhere, temporal triggers, most of all Every Minute, should be used only with care because they might result in keeping DEVONthink permanently busy. But @Plinth said that their Smart Rule should “always move any item” from the Global Inbox, i. e. wipe it clean in every go. So the Smart Rule would simply check every minute if there is any file in the Global Inbox—and if so, move it—and DEVONthink can handle that without breaking a sweat.