Adium import script hangs...


I’ve got DT Pro 1.5.1 and Adium 1.2.3 running on Leopard.

When I run the Import Adium Chatlog, everything looks good for a while, but then the script stops on a certain person’s file (I let it run for a good hour) and I can’t get control back. ‘Cancel’ button does nothing, and I have to Force Quit DT.

I know nothing about AppleScript, I’m afraid, though I am technical. Any clues where to start troubleshooting?

[P.S. If I remove that user’s folder from the logs directories, the import works fine. But that’s my most important support chat-ee, so I need her in the db.]



Hmm, do you know which file could cause the hang? You could remove blocks of files in the folder, e.g., to a temporary folder on the Desktop, to see which one is causing the hickup.

I get the same hang, but for me it happens on the very first chat log.

Is the script restricted to importing only from a certain version of Adium? My chat logs go way back into the pre-history of the project.


The script was designed for the 1.2+ line of Adium, I have never tested it with an earlier version. It uses an external command line application for the actual conversion. Can you find out on which file/person it hangs and remove that from the chat logs folder? If the conversation is not too private, could you send me the files so I could check here? Maybe I need to set a timeout for the conversion to get over defective/old/broken logs…

Actually, I ended up writing a converter to turn my AdiumHTMLLog files (of which I had tons) into the newer XML .chatlog files. Even then I had to fix lots of files manually, because of little inconsistencies between the formats that my script could not handle.

Then I ran into an Applescript bug which I fixed by changing the “set shellScript” line to:

set shellScript to ("xsltproc --stringparam title \"" & newChatlogName & "\" --stringparam person \"" & chatlogPerson & "\" -o \"" & (tempPathPOSIX & "/" & chatlogPerson & "/" & chatlogFile) as string) & "\" \"" & xslPath & "\" \"" & chatlogPath & "\""

Note the lack of #!/bin/sh and the deletion of two linefeeds.

After all this, and about 8 hours worth of trying and re-trying, I finally got all 3400 or so of my old chat transcripts imported. Yay DTP!


Thank you! Maybe the AdiumHTMLLog converter could be interesting for other users, too? Or could you send me one of these files so that I can at least exclude them from being accidently processed?

Now in 2009 the import Adium chat log on snow leopard hangs on cacheing address book data latest beta 7.

Without telling anyone Apple has made some subtle changes in the AppleScript API of Address Book. Please try this updated script:

_x Adium (38.7 KB)
It should work with both Mac OS X 10.5 and 10.6.

Still having issues though different. the script seems to have parse errors mostly on IRC channels but in all different types.

and seemd to hang at the end. not actually importing anything.


Can you please send me copies of these problematic IMs? With my standard AIM and Yahoo IMs here I get no hangs or hiccups.

I attempted to use this modified Adium import script with 2.0b8, and it crashes DTPO every time. It is reproducible.

I have included the SL crash info in a file called “crash”, as well as a screenshot of the initial error I get when trying to do the Adium import.

Screen shot 2009-12-12 at 6.28.21 AM.png