Annotation file URL not populating original document

According to the user manual for DT3b3, “When you create an annotation file, its URL replaces the URL of the original document. This allows you to jump to the annotation from the navigation bar.” (This is the behavior that was provided in DT2 by the add-on annotation script/template.) But when I select “New from template” in the Annotations dropdown in the Inspector, the annotation file’s URL or internal link does not get added to the original document so there doesn’t seem to be any way to jump to the annotation. Am I missing something? With the annotation relegated to a separate group instead of being next to the original, that link is more necessary than ever.

This is incorrect in the documentation, which is also in beta testing. Changes in the documentation are made on each release. Thanks for your patience and understanding.

I wasn’t trying to point out incorrect documentation that needs to be corrected, but rather, what I consider undesirable program behavior that needs to be revised to conform to the documentation. An annotation file-creation process that does not place a readily-accessible link to the annotation file in the original file is useless, IMO. I browse my document list, not my annotations, and need to be able to access the annotations from the documents. It appears that I can still use the script that was available with DT2 to accomplish my purpose (albeit less conveniently), but I really don’t understand why such a important feature was omitted from the process built in to the annotations pane in DT3.

but I really don’t understand why such a important feature was omitted from the process built in to the annotations pane in DT3.

What “important feature” was omitted ?

The creation of the link from the original file to the annotation file.

Creating an Annotation file via the new method automatically inserts a back link into the file. You can also use Insert Back Link (and use Insert Quote with PDFs) at any time.

I think we are talking at cross purposes. “Insert Back Link” inserts a link TO THE ORIGINAL FILE into the Annotation File. I was referring to the link in the other direction: inserting a link TO THE ANNOTATION FILE into the original file.

When I use Data > New From Template with the DT2 Annotation template (copied in to DT3), and then display the original document (e.g., download.pdf) in preview or its own DT3 window, the navigation bar of that window displays the linked text "Go to “download (Annotation).rtf” which I can click to open the annotation file. The Info inspector for the pdf file has a “URL” starting with x-devonthink-item://. If that pdf file originally had the URL from which it was downloaded, it wilI have been copied into the Comments as “Original URL”.

If, on the other hand, I create an annotation file for download2.pdf using Annotations > New from Template dropdown in the Inspector, and then display that pdf (NOT the annotation file), its navigation bar still displays the original URL of the PDF. The original URL is not copied into the Comments, and unless I have missed something, there is no link anywhere to the annotation file itself, which is off in the Annotations group.

If I can’t open the Annotation file directly from the original file, it is useless to me.

seems related to this?

If I can’t open the Annotation file directly from the original file, it is useless to me.

You can.

You can clearly Open or Reveal the annotation file from this menu.

Well, as I’ve been saying, “unless I’m missing something”… and it appears this is what I was missing. In my defense, I did notice the menu options and tried them, but they didn’t work. After seeing your reply, I tried again, creating a new annotation file, and both menu options now worked. More experimentation seems to indicate a possible bug, however. Here’s what happened:

  1. I select the annotation file in the item list. The annotation file is displayed in the main window.
  2. Next I click on the link to the original file in the annotation file. The original file is displayed in the main window, and the Inspector is populated with its data, but the file is not selected in the item list.
  3. Finally, I select Reveal or Open in the Annotations dropdown. The Inspector panel changes to show the data for the annotation file, but the original file continues to be displayed in the main window; the annotation file itself does not reappear.
  4. Going to the open Annotation folder and selecting the annotation file also does not cause the annotation file to be displayed, and selecting the original file in the item list does not cause the Inspector to display the data for the original file.

This is why I didn’t realize those menu options were intended to Open or Reveal the annotation file – under this particular sequence of actions, they simply did not work. I assume this is a bug.