Apple Mail Add On

Hi, I am running OS Monterey v12.5 and DEVONThink v3.8.5. I am unable to get the Apple Mail add on to work. Once I have installed the add on the Bundle appears in the Library, but the extension is missing from the Mail Preference Pane. DEVONThink has full disk access and everything is in its default location. I have tried to quit both Mail and DT and then removed and reinstalled the add on and of course re-booted. The Bundle always appears in the Folder hierarchy but never appears in the Apple Mail Preference Pane. Can anyone help please?

It’s not an extension, the plug-in has to be enabled via Mail > Preferences > General > Manage Plug-Ins…

I realise that actually. My sloppy language. When I go to Mail>Preferences>General>Manage Plug-Ins, the plug-in is not there

Is your home directory on an external volume?

Yes it is

I figured. This is known to cause issues with Apple Mail.

Here is a link from the SpamSieve developer on trying to reset Mail
s private plugin folder.

It’s link

Okay thanks. I’ll try that when I’m home and can work with two computers!

You’re welcome.
May I ask why you’re running your home directory off a non-boot volume?

It was originally to save space. However, I’m home now and have copied the database to the home directory. I have gone through the steps of deleting the Mail Bundle in Finder (having first closed DT and Mail) and then reinstalled the plug-in. It still isn’t showing up, so I’ll take a look at the earlier advice ver at Spam Sieve

Let us know how it goes.

Hi, that hasn’t worked. I tried both of the recommended solutions, but unfortunately, that plug-in is not picked up by Mail. I have uninstalled and reinstalled DT as a last resort, but no joy.

Hold the Option key and choose Help > Report bug to start a support ticket.

Hi I’ve done so. Thank for your help!

1 Like

Try this. I believe this will fix it:

Quit Mail

Open and type the following two commands one after another (hitting return after each):

sudo -u root defaults write “/Library/Preferences/” EnableBundles -bool true

defaults write EnableBundles -bool true

Relaunch mail and check Preferences > General again. The “Manage Plugins” button should appear near the bottom of the window.

Hi Chris,

Thank you, yes this has fixed it. Well done!


1 Like

That’s interesting as that should be on by default, but we’re glad to hear it worked for you. :slight_smile:

Glad it worked for you!

Usually a sign of a locked up Apple Mail plugin vault that requires resetting.