Apple Mail Plugin not working on macOS Sierra

Just wanted to confirm the above instructions (rename plist file) works fine.
Plugin successfully enabled in Sierra Mail 10.0

Thank you. Actually, I’d rather the software were just updated already. Know not officially released, but public beta’s of it probably being used much.

Updates of DEVONthink for the public beta releases of an OS update would be a poor use of developer resources, which are targeted to the improvement of DEVONthink itself.

By definition, a public beta of Mac OS is a moving target, designed to find bugs and uncover issues. Even after the Gold Master release of a beta OS, Apple may (and sometimes has) made significant code changes in the public release.

The developers are aware of issues posed by beta releases, but trying to update the current version of DEVONthink for each beta OS release would be somewhat like a dog chasing its tail. Such an effort would use far more resources than could be justified for achievement of compatibility with the final public release.

That’s why we (and Apple itself) emphasize that a beta OS should not be used for a real working environment.

Just to amplify Bill’s point… Apple just released a second gold master for Sierra. :smiley:

Thanks, @alanshutko. Exactly the point. :smiley:

Should be noted that 320, 322 and the 323 “updates” were because of daily build numbering and movements to Siri servers and servers for official release today. No other changes. Of course that wasn’t know publicly or by developers apparently, but in any case today it was officially released (323), so again, I am hoping for an update soon to address the problematic plugin for DTPO.

Just to confirm that the Plug-in is disabled by the official Sierra release: “Contact the makers of these plug-ins for versions that are compatible with Mail 10.0”

Yes, remains the same. was hoping for an update today with Sierra coming out. Hopefully tomorrow.

Just to follow up in this thread, Christian has announced that a version supporting Sierra is currently in beta, and should be out later this month.

UGH! would be my reply on the delay.

There are more issues than the Mail plugin at hand. As it has been since Mavericks release, the QA from Apple appears to not have improved (especially concerning Mail). Also, the have made some big changes under-the-hood that are affecting more than just our apps.

PS: You should still be able to drag and drop from Apple Mail to DEVONthink.

Yep… heard SnapScan wasn’t prepared with their app. I do drag, but it still takes forever compared. Lots of spinning for some reason.

And more than they have been affected by changes to the PDFKit and text frameworks. :confused:

What is a good way to drag and drop Mail in to DTPO?

I just dragged it to the Devonthing symbol in my dock, told it in what group I wanted it as with all normal files but are just getting a Bookmark.

Bookmark works fine but I have no way of knowing what the mail is all bout.

Just a long text saying: message:%C and so on.

The Dock is only useful for real files/folders, otherwise the results might be unexpected as the Dock’s drag & drop support is kind of weird & limited. Therefore the best workflow is to drag & drop the emails to a window of DEVONthink or to the Sorter.

Thanks! Works like a dream.

Mail plug-in now works perfect with latest update!

Thanks DevonThink.

With 2.9.5 first the mail import works now perfect, but after one day it stops working …
Do I have to remove an old file?

I don´t think so, mine has worked every day since I installed it after the download.

Just try to Install Plugins again inside Devonthink. However I don´t think all versions of DT can import mails, I have the DevonThink Pro Office version.