Apple pencil not drawing in RTF or Formatted Note?


First I’d like to say I very much enjoy using DTTG with Apple Pencil to write handwritten notes. I use lined PDF templates and it all works like a charm for me. Even long notes seem to pose no problems for the iPad and in dark mode the page inverts splendidly (white ‘ink’ on black background with faint white lines).

Today, I was attempting to create a drawing/handwritten note with Apple Pencil in both a Formatted and RTF note. I tap on the drawing icon (squiggle), use the pencil to write something, tap Done, and then nothing appears in the document. Am I doing something wrong/incorrectly? Or do these note types support drawings in a way I am misunderstanding?

I am using DTTG V3.7.7 on IPad Pro with ios 17.1.

Many thanks in advance for your help,


Where do you see the “drawing icon (squiggle)” in a formatted note?

It is a sub-menu under the ‘insert item’ icon:

1 Like

I am not seeing an issue with inserting a drawing into either a formatted note or RTFD document. However I do see a bug with the tools and am filing an issue on it.

Are you seeing the drawing tools palette appears and immediately disappear? If so, does it appear the pencil color is the same as your background, e.g., white on white?

It’s not working for me either; also camera/photo fails

fwiw If I screenshot the drawing, I can copy/paste into the note

Hmm… I’m not seeing any issue inserting photos or a new picture via the camera.
Are you on iPadOS 17.x?

Yes, current versions of OS and DTTG
Working with a Formatted Note

1 Like

Hello. Yes, the drawing tools palette appears; I draw/write something, click Done. The drawing is not inserted into the document. Yes: the ink is black, the page is white. Thanks for your help, I do appreciate it.

I also have trouble with this. When I select the Insert Photo or Video option, it presents me with the media/photo picker; I then select something, but there is no UI element with which to confirm the selection/insert it into the document. If I press return after making a selection, nothing happens (photo picker remains, with item selected).
I am able to copy/paste or drag photos/images into a document (RFT, Formatted) successfully, just not via the Insert Photo menu item.
Thanks again for all of your hard work.

You’re welcome (though the heavy lifting is done by the wizards in development) :smiley:

Does the behavior persist after rebooting the device?

Yes, I am sad to report that the behavior persists after rebooting.
And that’s ok! Not optimal, but ok. The application still offers heaps of funcationality for my daily use and I am grateful for that (thank you, Dev wizards).
If it is eventually resolved, I will be delighted with ability to combine text and handwriting in RTF/Formatted notes.
I’ve tried a dozen different apps specifically geared for handwritten notes and I still feel like DTTG offers the most straight-forward approach with a set of tools that makes sense to me.
(Among the apps I tried very hard to like was Apple Notes, but it seems to have so much going on in the background that it is actually not a stable environment for longer handwritten notes. I suspect this may have something to do with the fact that it is indexing all of the things (text, text in pdfs, handwriting itself) all the time.)
Thanks again for your help. Have a lovely day.

1 Like

You’re welcome and thank you for the patience and grace. It’s appreciated :heart::smiling_face:

1 Like

For me; Apple Notes works; Notability is better
I export the note in pdf format to Devonthink

Want to bump this thread. Using the latest DTTG on the latest iOS and using the insert button to add drawings or photos doesn’t work still. The window to draw or attach photo appears, but once you have made your drawing or selected your photo and press done, it takes you back to your note with no photo or drawing appended.