Apple Pencil PDF markup issue

I’m running the latest iOS 13.3 along with DTTG 2.7.6 (16388) on a new iPad Air (3) with the original apple pencil.

I was interviewing someone and taking notes over their PDF resume using the apple pencil. This was mostly fine, but about four or five times during the interview, the annotation engine would suddenly draw a straight line of ink from a point on the edge of the paper to wherever the pen was. It was almost as if it “lost track” of the pen’s location, reset it to a point on the border of the screen, and then drew a line to the current location to “catch up.” This happened a number of times and was so bad that I haven’t been back to it since.

Anyone experience this?

Don’t use DTTG to make that kind of annotations. I use GoodNotes that has a zoom feature to write in the lowest part of the iPad, and once finished, export to PDF and send to DTTG.

I use GoodNotes to make a scrapbook of each of my professional readings when normal PDF annotation is not enough or I don’t want the original document with annotations, pasting captures and annotations, links/images from external stuff, scraps of the original PDF and so on. Once finished, I export to PDF and send into DTTG in order to go to DT as my main repository of all.

1 Like

No, I haven’t seen this issue recently (though it had occurred in the past).
What iPad and are you using the new Apple Pencil or the first generation one?

Original pencil on a 2019 iPad Air.

Okay. Thanks!

  • Is this consistently reproducible?
  • Has it occured with more than one PDF?

This used to happen to me, frequently enough that I stopped using DTTG for pdf markup. I was using a 2017 iPad Pro with original Apple Pencil. This was back in late 2017 and I’ve barely done any markup in DTTG since then. GoodNotes is much the better app for markup, even if it weren’t for bug.

Sorry - it took a while. It definitely happens with more than one PDF, but it’s not particularly “easy” to make happen - it may be something behavioral such as my palms on the screen interfering?

One interesting tidbit is that once it does this, I can erase the errant straight line that gets drawn except for some portion of it that starts off of the page, where I’m not allowed to erase.

Re: other people’s replies about GoodNotes - I appreciate the alternative, but also want to see DT improve over time - I’m invested here.

1 Like

I have the same issue with the 2018 10 inch ipad pro. is there anything on the way for this, or do you recommend switching to goodnotes as suggested?

Same setup here with no issues.

I noticed the exact same errant lines appear while drawing with my finger in another app called Khan Academy Kids. Makes me think the problem is not tied to the pencil, but rather to whatever drawing engine both apps use.

Same here. I have a 2018 iPad Pro, iOS 13.3.1.

I keep getting lines shooting up to the top right corner when writing/ marking up using the pencil. It has only happened to me since the last DTTG update to v 2.7.7, and I was wondering if it had something to do with the change to the toolbar.

It’s frustrating, as markup was really good before.

Is the side of your hand resting on the iOS device when using the pencil? It could be an issue with the palm rejection.

Hi @BLUEFROG - thanks very much for responding.

Yes, my palm is always resting on the screen when it happens. I just tried it again and after writing approx 10 words the line shot down to the bottom middle of the screen, not far from where my hand was, so it probably does have something to do with palm rejection

It had never happened, though, before the upgrade to DTTG v 2.7.7 (approx 6-8 months with no instances), so I was wondering if something in the upgrade wasn’t playing along with the palm rejection in iOS.

Maybe the timing of the upgrade is a coincidence. I didn’t think the problem necessarily came in with iOS 13.3.1 because it doesn’t happen with other apps (GoodNotes, PDF Expert, LiquidText) (where I also (always) rest my hand on the screen) - I’ve only had the problem so far with DTTG.

It only seems to happen with the pen - the highlighter is fine.

It’s more a nuisance than a burning issue but if you or anyone else comes across a fix, that would be great, as being able to mark up documents inside DTTG has been really useful and saved a lot of time messing round with sharing to and from other apps.

I do have the exact same issue. Maybe it is possible to disable touch input if an Apple Pencil is connected? I guess that might help in a couple of scenarios.

What also keeps happening a lot is that the page suddenly changes. This happens most likely because the “Page Navigator” thing on the bottom activates and my palm “selects” a slide. I’d like an option to disable that, if possible.

That would be up to the PDF framework developer. We can just pass along the requests.

1 Like

i have had this issue too - only since the most recent dttg update. no problems opening the pdf in, it only happens in dttg. also it happens in one page pdfs.

Welcome @stumpy075

As I noted, this has to go to the PDF framework’s developer.

1 Like

i’m sorry bluefrog but could you explain that response to me please? i’m not sure i get it.

i’m saving my PDFs from iOS via the share sheet. if i save the pdf to and open it/mark it up using the files app, i have no problems. the problem only happens if i capture the pdf to dttg and mark it up there. are two separate PDF frameworks involved in those two processes?

also I’ve experienced the problem without my palm on the display - i.e. it’s not a palm rejection issue in my case.

They use a 3rd party library to handle PDF in DTTG, then they are passing the issue to the 3rd party developer in order to resolve it, as they cannot do.

I had a bug about a year ago with PDF and after collecting debug information, they sent it to the 3rd party developer and they released a new updated version.

Depending on the time PDF implementer will take to resolve the issue, you will get a new DTTG updated with that solved.

On my experience, both Devon and PSPDFKit (the 3rd party developer) are very proactive and will resolve the issue.

They only need patience from we customers.

1 Like

ah ok. thank you for the response rfog, that’s much clearer now