archive zipped backup to DropBox failed because "file in use

Sorry if this has been covered, but I searched and couldn’t find anything. I modified the “Daily Backup Archive” script just enough to change the target to DropBox, since I wanted the archives somewhere other than on my computer. (And that’s all I did; I was very careful, because scripting is really not my thing.)

It worked in the sense that it tried to archive to the correct target, but I got a DB error message saying something like “cannot be completed because file is in use.” Well, yes: as far as I know the database has to be open to run the script. Does anyone know how I can solve this? (In the meantime my data is safe: I have copied the database to two different external drives and another computer; the problem with doing that as an ongoing backup is that it’s slow.)


I know it’s been a while, but I had this same thing appear when I tried to have the archive script place the zip-file in my Dropbox: “cannot be completed because file is in use”

I think it may be because the archive script opens an incomplete file at the beginning of the zip/compression process, and then it takes so long to complete the compression that it confuses Dropbox.

With a large database to compress this might be more likely. Mine’s almost 2 GB.

I tried removing the finally complete zip file and returning it to the Dropbox and it seems to be working, but the upload on my home internet says it will take 12 hours. Sigh. Only worth doing a few times a month maybe for an “if all else fails at least I’ve got this” occasional backup.

I’ll be doing non-cloud backups locally and off-site as primary backups.