Are iWork Pages files indexed/searchable?

I was thinking that I’d like to store some of my client letters in the Devonthink database so that I can more easily search/find them in the future.

So, I drag/dropped a .pages document into Devonthink. It shows up and previews just fine.

However, when I search for text that is in it, DT does not find the document.

For example, the letter starts with the line “You requested information about the…”

If I type “You requested information about…” I get zero results. :frowning:

Is DT unable to index .pages files, or is something going wrong here?

Thanks!

DEVONthink can import or index .pages files and search for content. It cannot highlight the found text, because .pages preview is just an image file. Make sure you’re using the latest version of Pages.

Here’s a shot of a sample file with the Words sidebar displayed in DEVONthink to show that the content of the file is known to DEVONthink.

I am not seeing any issue here with searching in Pages documents. Make sure your searchScope (under the magnifying glass) is set to content.

Thanks for the responses.

Korm wrote

Are you referring to the brand new version of Pages just released with Sierra? I haven’t upgraded yet, and don’t plan to for a while until the bugs shake out.

I do have the latest version on El Capitan.

Thanks

Just as a side note: My testing was on the ancient OS X 10.9.5. :smiley:

I’m not sure what else to try… I have set the search scope to content and tried both fuzzy and non fuzzy search. It simply won’t even list the document in the found item list… it acts just like it does, when it doesn’t find text.

I am using the last version of Pages on El Capitan. So, I guess I should have said “the penultimate version of Pages”!

I usually leave Scope at “All” – and did for my test of this.

Select one of your Pages files and click View > Text Alternative. You should be able to see a text-only (no layout, no styling) version of the document. If not, then there’s something wrong with the file(s).

Thanks for noting this… the “view -> Text Alternative” is grayed out, for both my pages documents and even for RTF docs.

Do you have any idea what else to try?

I’m using DTPO 2.9.4 on El Cap.

Morgan

Is the set to In Selection?

Also, note that if a hit is found, it will not highlight in the text unless the document is saved with a preview in Pages.

Yes, I select it and then choose the “View” menu, and that item is grayed out.

Yes, that’s the same point Korm made. However, my problem is not the lack of highlighting - it’s the lack of finding any results whatsoever when I search for it.

Thanks

Sorry. I meant, is the searchScope set to In Selection?

Hi, yes, I just tried that, and it still won’t find it. I have a PDF version of exactly the same letter that it finds with this search, but it won’t find the pages document.

Could you please start a Support Ticket and ZIP and attach the problematic document? I’ll see if I can replicate it here. Thanks!