Automatic update of indexed group not working for parent

Hello all. I am trying to understand if this is normal, and if there is anything I can do:

– I have in my local filesystem several PDFs with articles, which are stored in the following folder hierarchy: bibliography / author / date / article.pdf. Each author may have one or more date folders, and inside them the corresponding articles.

– I have indexed the bibliography folder in DT, which became an indexed group;

– I often add more folders (authors) to the bibliography folder, but they do not get indexed automatically in DT – I manually have to index the folder;

– BUT if I add a folder (Date) to an existing Author folder, then the corresponding group gets automatically created in DT.

Is there any way I can tell DT to automatically index every change inside the bibliography folder?


DEVONthink automatically updates the index of a group when you select/expand the group in the list, split, or 3-pane view. The group and its contents are updated-not the complete hierarchy of the index. Meaning, if you select your group ‘bibliography’ it will update its contents, but not the contents of ‘author’, ‘date’, etc. If you select the bibliography group, then newly added author folders should be automatically indexed into the database, but you will need to select the authors groups to update the contents of the groups. Note also that the update is one-way only-documents you add to these groups in DEVONthink will not be automatically exported out to the indexed folders in the filesystem.

If your bibliography group is at the root level of the database, there is a script ‘Update indexed Items of all database’ in the Support Assistant (Help Menu) that, when executed, will update all levels of the bibliography group. If you have indexed groups nested inside non-indexed groups, then you will want the script that korm created and posted in this thread.

Thanks for the quick reply… unfortunately I still can’t make it work…
From the root of the database, I had:

“Sources” (non-indexed group) / “Bibliography” (indexed group) / “Author” (indexed group) / “Date” (indexed group).

Any change is “Author” or “Date” by using the OS filesystem gets reflected in DT Database, but If I change “Bibliography” (i.e. adding a folder or file) it doesn’t get indexed in the DT.
Tried using the script provided, choosing indexing all levels, but still doesn’t cut it out.

Moved “Bibliography” to the root of the DT DB, but still not working …

Perhaps it has something to do with the first selection on what to index? (I selected “Bibliography”)…

thanks for the patience

Just tried erasing everything and starting over. Re-indexed and things are working as they should! Thanks for clarifying how the index mechanism works.