Automatically take ReadOnly PDFs -> ReadWrite

One of my research sources (Oxford Review) creates PDFs that are marked readonly only. They don’t understand why this happens. Rather than debug their authoring process I would like to create a smart-rule that finds readonly pdfs when they arrive in the inbox and duplicates them as writable.

Is this possible? I can’t find anything in the matching rules for ReadOnly PDFs.

If it helps I could do this with AppleScript or using Hazel.

There is no criteria for a read-only state nor is there an action or AppleScript command to change this specific state.
You could try Data > Convert > To Paginated PDF.

Is there an Automator or AppleScript I could run to copy the file and strip the readonly attribute buried inside the PDF? I ask because I already have Hazel moving these files to the inbox. I know the Preview app is capable of making a writable copy, because that is how I currently work around the problem in a fully manual fashion.

What exactly are you doing in Preview to modify this?

PS: Whoever is generating the PDFs should be looking for a resolution to this issue.

PPS: Select a PDF in the Finder, compress it, and attach it to a new support ticket.

I asked the OR and they don’t know what is creating the problem, now I wonder if it is a DT problem. I export the file from DT to a new folder it is editable. However inside DT it isn’t. This also happened when I downloaded: (PDF) Tell Me What I Did Wrong: Experts Seek and Respond to Negative Feedback (JCR) | Ayelet Fishbach and Stacey Finkelstein - and imported the Document into DT. Its marked Readonly. Where as when it’s on the filesystem it’s editable.

Editable via… what?

When the files are still sitting in my downloads folder I can edit them. When they’re moved to the inbox in DT they’re become uneditable. (BTW Isn’t it night time for you?)

Actually, I do keep weird hours but I’m in the US. :slight_smile:

Are you referring to not being able to annotate a PDF in the Global Inbox as being “uneditable”?

Somehow I assumed all of the DT was in Germany. Now I know :slight_smile:

yes. Hopefully this ScreenShot shows the problem:

This might be an automatic protection to prevent possible issues after editing the document due to PDFkit bugs. The next release will include a hidden preference to disable this. In the meantime one workaround is to convert the document to a new paginated PDF (via Data > Convert).

I will wait for the next release. However your comment says: “after editing”. Except the lock symbol in DT is present before I try to annotate/highlight.

Exactly as editing might cause the issues.